aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-07-22 09:52:02 +0800
committerijliao <ijliao@FreeBSD.org>2004-07-22 09:52:02 +0800
commite1a2ab7387623bcc86ac7eebd74cae4f4bfc3db9 (patch)
tree56ede4c8aa8adf253d5b1b56fd2de13c81605f3e /graphics
parent5f7bd3e845503359bf5a5f6b8f99182868310e67 (diff)
downloadfreebsd-ports-gnome-e1a2ab7387623bcc86ac7eebd74cae4f4bfc3db9.tar.gz
freebsd-ports-gnome-e1a2ab7387623bcc86ac7eebd74cae4f4bfc3db9.tar.zst
freebsd-ports-gnome-e1a2ab7387623bcc86ac7eebd74cae4f4bfc3db9.zip
upgrade to 1.2
PR: 69363 Submitted by: maintainer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zphoto/Makefile29
-rw-r--r--graphics/zphoto/distinfo4
-rw-r--r--graphics/zphoto/pkg-plist9
3 files changed, 30 insertions, 12 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index f453101447b0..62780dab5ce5 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 1.0
+PORTVERSION= 1.2
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,33 +16,42 @@ COMMENT= Zooming photo album generator
LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
Imlib2.2:${PORTSDIR}/graphics/imlib2 \
- popt.0:${PORTSDIR}/devel/popt \
- aviplay.0:${PORTSDIR}/multimedia/avifile
+ popt.0:${PORTSDIR}/devel/popt
+.if !defined (WITHOUT_AVIPLAY)
+LIB_DEPENDS+= aviplay.0:${PORTSDIR}/multimedia/avifile
+.endif
.if defined (WITH_WXGTK)
LIB_DEPENDS+= wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
.elif defined (WITH_WXGTK2)
LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
.endif
+.if !defined (WITHOUT_ZIP)
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+.endif
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}"
-.if defined (WITH_WXGTK) || (WITH_WXGTK2)
+.if defined (WITH_WXGTK)
+CONFIGURE_ARGS+= --with-wx-config=wxgtk-2.4-config
PLIST+= ${PKGDIR}/pkg-plist.wxzphoto
+.elif defined (WITH_WXGTK2)
+CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.4-config
.else
-CONFIGURE_ARGS= --disable-wx
+CONFIGURE_ARGS+= --disable-wx
+.endif
+.if defined (WITHOUT_AVIPLAY)
+CONFIGURE_ARGS+= --disable-avifile
+.endif
+.if defined (WITHOUT_ZIP)
+CONFIGURE_ARGS+= --disable-zip
.endif
USE_GMAKE= yes
USE_XLIB= yes
post-patch:
@${REINPLACE_CMD} -e 's|<ming.h>|<ming/ming.h>|g' ${WRKSRC}/*.c ${WRKSRC}/configure
-.if defined (WITH_WXGTK)
- @${REINPLACE_CMD} -e 's|wxgtk2-config||g' -e 's|wxgtk2-2.5-config||g' -e 's|wxgtk2-2.4-config||g' ${WRKSRC}/configure
-.elif defined (WITH_WXGTK2)
- @${REINPLACE_CMD} -e 's|wx-config||g' -e 's|wxgtk-config||g' ${WRKSRC}/configure
-.endif
+
.include <bsd.port.mk>
diff --git a/graphics/zphoto/distinfo b/graphics/zphoto/distinfo
index 87d6a756b9fb..f00edac2d5d3 100644
--- a/graphics/zphoto/distinfo
+++ b/graphics/zphoto/distinfo
@@ -1,2 +1,2 @@
-MD5 (zphoto-1.0.tar.gz) = 7cba659b913468124b664bcde52efece
-SIZE (zphoto-1.0.tar.gz) = 419086
+MD5 (zphoto-1.2.tar.gz) = 636a9cffec9131043e29c1f5812a6c3c
+SIZE (zphoto-1.2.tar.gz) = 414079
diff --git a/graphics/zphoto/pkg-plist b/graphics/zphoto/pkg-plist
index 80674e30c911..98fbe669c3df 100644
--- a/graphics/zphoto/pkg-plist
+++ b/graphics/zphoto/pkg-plist
@@ -5,12 +5,14 @@ share/zphoto/templates/default/en/noflash.html
share/zphoto/templates/default/en/zphoto.css
share/zphoto/templates/default/en/flash-colors.txt
share/zphoto/templates/default/en/css-colors.txt
+share/zphoto/templates/default/en/zoom.js
share/zphoto/templates/default/ja/.photo.html
share/zphoto/templates/default/ja/index.html
share/zphoto/templates/default/ja/noflash.html
share/zphoto/templates/default/ja/zphoto.css
share/zphoto/templates/default/ja/flash-colors.txt
share/zphoto/templates/default/ja/css-colors.txt
+share/zphoto/templates/default/ja/zoom.js
share/zphoto/templates/default/all/.photo.html
share/zphoto/templates/default/all/zphoto.css
share/zphoto/templates/default/all/index.html.en
@@ -19,8 +21,14 @@ share/zphoto/templates/default/all/noflash.html.en
share/zphoto/templates/default/all/noflash.html.ja
share/zphoto/templates/default/all/flash-colors.txt
share/zphoto/templates/default/all/css-colors.txt
+share/zphoto/templates/default/all/zoom.js.en
+share/zphoto/templates/default/all/zoom.js.ja
share/zphoto/doc/zphoto-ja.html
share/zphoto/doc/zphoto.html
+share/zphoto/doc/images/wxzphoto-linux-mini.png
+share/zphoto/doc/images/wxzphoto-linux.png
+share/zphoto/doc/images/wxzphoto-mini.png
+share/zphoto/doc/images/wxzphoto.png
share/zphoto/fonts/EfontSerifB.fdb
share/locale/ja/LC_MESSAGES/zphoto.mo
share/locale/ja_JP.SJIS/LC_MESSAGES/zphoto.mo
@@ -30,5 +38,6 @@ share/locale/ja_JP.SJIS/LC_MESSAGES/zphoto.mo
@dirrm share/zphoto/templates/default
@dirrm share/zphoto/templates
@dirrm share/zphoto/fonts
+@dirrm share/zphoto/doc/images
@dirrm share/zphoto/doc
@dirrm share/zphoto