aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2018-03-11 23:40:02 +0800
committerbrnrd <brnrd@FreeBSD.org>2018-03-11 23:40:02 +0800
commite711f83ad0172a342d14a0aa5d20bd00ca1b30a3 (patch)
tree91599da090dc0032a3b6e1eb464518f8fc1b3aac /graphics
parenta205416d8ba4a88d48174160994c662db677cd4a (diff)
downloadfreebsd-ports-gnome-e711f83ad0172a342d14a0aa5d20bd00ca1b30a3.tar.gz
freebsd-ports-gnome-e711f83ad0172a342d14a0aa5d20bd00ca1b30a3.tar.zst
freebsd-ports-gnome-e711f83ad0172a342d14a0aa5d20bd00ca1b30a3.zip
graphics/mapcache: Fix regression with Mk/Uses/apache.mk
With hat: apache Reported by: antoine Approved by: fixit blanket
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mapcache/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/graphics/mapcache/Makefile b/graphics/mapcache/Makefile
index 01ae0c359a11..48689e23d4e8 100644
--- a/graphics/mapcache/Makefile
+++ b/graphics/mapcache/Makefile
@@ -30,8 +30,10 @@ OPTIONS_DEFAULT= APACHE FASTCGI SQLITE GEOS GDAL
OPTIONS_SUB= yes
APACHE_DESC= Native apache module
-APACHE_USE= APACHE=22+
-APACHE_CMAKE_ON= -DWITH_APACHE=1
+APACHE_USES= apache:2.2+
+APACHE_CMAKE_ON= -DWITH_APACHE=1 \
+ -DAPACHE_INCLUDE_DIR=${LOCALBASE}/${APACHEINCLUDEDIR} \
+ -DAPACHE_MODULE_DIR=${LOCALBASE}/${APACHEMODDIR}
APACHE_CMAKE_OFF= -DWITH_APACHE=0
FASTCGI_LIB_DEPENDS= libfcgi.so:www/fcgi
@@ -76,9 +78,4 @@ GEOS_LIB_DEPENDS= libgeos_c.so:graphics/geos
GEOS_CMAKE_ON= -DWITH_GEOS=1
GEOS_CMAKE_OFF= -DWITH_GEOS=0
-post-patch:
- @${REINPLACE_CMD} -e 's|PATH_SUFFIXES|PATH_SUFFIXES \
- ${APACHE_SUPPORTED_VERSION:S/^/apache&/}|g' \
- ${WRKSRC}/cmake/FindAPACHE.cmake
-
.include <bsd.port.mk>