aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-18 16:47:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-18 16:47:31 +0800
commite826b5e74616d9321d2c4f291f0f8de42e189852 (patch)
tree2e7efe898622c1415ef112d3cb11991db31f4790 /graphics
parent665a3a277dc8d6ff3335acef18c7f2d2dacb45fe (diff)
downloadfreebsd-ports-gnome-e826b5e74616d9321d2c4f291f0f8de42e189852.tar.gz
freebsd-ports-gnome-e826b5e74616d9321d2c4f291f0f8de42e189852.tar.zst
freebsd-ports-gnome-e826b5e74616d9321d2c4f291f0f8de42e189852.zip
Conditionalize the addition of -Wno-c++11-narrowing to fix clang6 errors
in CFLAGS to affect clang-based archs. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glosm/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index ff6aea0c9363..5bd294687070 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libexpat.so:textproc/expat2
-USES= tar:bzip2 cmake
+USES= cmake compiler tar:bzip2
USE_GL= gl
USE_XORG= x11
USE_SDL= sdl
@@ -24,7 +24,8 @@ USE_GITHUB= yes
GH_ACCOUNT= AMDmi3
TEST_TARGET= test
-CXXFLAGS+= -Wno-c++11-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
PORTDOCS= README ChangeLog