aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-28 17:36:56 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-28 17:36:56 +0800
commitea3c160881eb60292f774b135239dcf59b5fdfaa (patch)
tree5b1656d091ca74a23ee2a9be5fc60e5f9fc374fb /graphics
parent6d36f8955989ea766354bf6dc7b19885bf353df8 (diff)
downloadfreebsd-ports-gnome-ea3c160881eb60292f774b135239dcf59b5fdfaa.tar.gz
freebsd-ports-gnome-ea3c160881eb60292f774b135239dcf59b5fdfaa.tar.zst
freebsd-ports-gnome-ea3c160881eb60292f774b135239dcf59b5fdfaa.zip
Downgrade C++03 to C++98, actual default for GCC < 6
GCC 4.2 in base system doesn't support C++03: cc1plus: error: unrecognized command line option "-std=gnu++03"
Diffstat (limited to 'graphics')
-rw-r--r--graphics/animorph/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
index eb2d5f0d2a9d..3164e919df56 100644
--- a/graphics/animorph/Makefile
+++ b/graphics/animorph/Makefile
@@ -12,16 +12,12 @@ COMMENT= Morphing engine for MakeHuman
LICENSE= LGPL21
-BROKEN_mips= fails to compile: unrecognized command line option "-std=gnu++03"
-BROKEN_mips64= fails to compile: unrecognized command line option "-std=gnu++03"
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-std=gnu++03"
-
GNU_CONFIGURE= yes
USES= pkgconfig gmake libtool
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
USE_GCC= any # otherwise graphics/makehuman won't link
-USE_CXXSTD= gnu++03 # The port is not compatible with C++11 and later.
+USE_CXXSTD= gnu++98 # The port is not compatible with C++11 and later.
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib