aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-02-01 05:36:11 +0800
committerjbeich <jbeich@FreeBSD.org>2018-02-01 05:36:11 +0800
commitebea28d651f0af342068973e7f98a91a5951c00f (patch)
tree9ce03f3b1e9e1e782c05864c48631852ec01165b /graphics
parent67e50bed96e571df1172d52b047cd59a1936aae0 (diff)
downloadfreebsd-ports-gnome-ebea28d651f0af342068973e7f98a91a5951c00f.tar.gz
freebsd-ports-gnome-ebea28d651f0af342068973e7f98a91a5951c00f.tar.zst
freebsd-ports-gnome-ebea28d651f0af342068973e7f98a91a5951c00f.zip
graphics/colmap: drop Clang workaround
Diffstat (limited to 'graphics')
-rw-r--r--graphics/colmap/files/patch-src_util_CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/graphics/colmap/files/patch-src_util_CMakeLists.txt b/graphics/colmap/files/patch-src_util_CMakeLists.txt
deleted file mode 100644
index 3d718744e4fa..000000000000
--- a/graphics/colmap/files/patch-src_util_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-build: prevent Clang < 4.0 crashing on i386
-
---- src/util/CMakeLists.txt.orig 2016-08-09 10:34:35 UTC
-+++ src/util/CMakeLists.txt
-@@ -23,3 +23,10 @@ COLMAP_ADD_TEST(random_test random_test.
- COLMAP_ADD_TEST(string_test string_test.cc)
- COLMAP_ADD_TEST(threading_test threading_test.cc)
- COLMAP_ADD_TEST(timer_test timer_test.cc)
-+
-+if(IS_CLANG AND CMAKE_SIZEOF_VOID_P EQUAL 4
-+ AND CMAKE_CXX_FLAGS MATCHES "-O([2-9s]|fast)")
-+ # -O2 exceeds max memory on i386
-+ set_source_files_properties(camera_specs.cc
-+ PROPERTIES COMPILE_FLAGS "-O1")
-+endif()