aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-05-31 19:03:52 +0800
committerdanfe <danfe@FreeBSD.org>2016-05-31 19:03:52 +0800
commitf1647a664af4828aea01b7cf7898880a23bda0d9 (patch)
tree22865b082de3268b913038b07cb55593f9ee0491 /graphics
parentec4e419b3c1baaa40eb9c7913ed2434c199adbb7 (diff)
downloadfreebsd-ports-gnome-f1647a664af4828aea01b7cf7898880a23bda0d9.tar.gz
freebsd-ports-gnome-f1647a664af4828aea01b7cf7898880a23bda0d9.tar.zst
freebsd-ports-gnome-f1647a664af4828aea01b7cf7898880a23bda0d9.zip
- Update to version 2.9 and drop no longer needed GH_TAGNAME
- Unbreak the build by putting `sip_build' on the USE_PYQT list - Patch generated sipAPIexpreditor.h file to allow building against newish libc++ 3.8.0
Diffstat (limited to 'graphics')
-rw-r--r--graphics/seexpr/Makefile7
-rw-r--r--graphics/seexpr/distinfo4
-rw-r--r--graphics/seexpr/files/patch-src_SeExprEditor_CMakeLists.txt11
3 files changed, 16 insertions, 6 deletions
diff --git a/graphics/seexpr/Makefile b/graphics/seexpr/Makefile
index 4969fd5786f9..3ad7ffbe04b6 100644
--- a/graphics/seexpr/Makefile
+++ b/graphics/seexpr/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= seexpr
-DISTVERSION= 1.0.1.2015.08.29
-PORTREVISION= 1
+DISTVERSIONPREFIX= v
+PORTVERSION= 2.9
CATEGORIES= graphics math
MAINTAINER= danfe@FreeBSD.org
@@ -13,10 +13,9 @@ LICENSE= APACHE20
USE_GITHUB= yes
GH_ACCOUNT= wdas
-GH_TAGNAME= 36ffb818b8
USES= bison cmake compiler:c++0x pyqt:4 python
-USE_PYQT= gui_build
+USE_PYQT= gui_build sip_build
USE_QT4= moc_build qmake_build rcc_build uic_build gui opengl
MAKE_JOBS_UNSAFE= yes
diff --git a/graphics/seexpr/distinfo b/graphics/seexpr/distinfo
index 125f0b64e03a..1f395fb53ad1 100644
--- a/graphics/seexpr/distinfo
+++ b/graphics/seexpr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wdas-seexpr-1.0.1.2015.08.29-36ffb818b8_GH0.tar.gz) = 8361adb26310060b063e37376625acb60314deac081130a397857f04884e2a7b
-SIZE (wdas-seexpr-1.0.1.2015.08.29-36ffb818b8_GH0.tar.gz) = 709489
+SHA256 (wdas-seexpr-v2.9_GH0.tar.gz) = 097642881f2c360d825f31e7c23881226386776dccbe8aa5b37c9ee0077601b2
+SIZE (wdas-seexpr-v2.9_GH0.tar.gz) = 709434
diff --git a/graphics/seexpr/files/patch-src_SeExprEditor_CMakeLists.txt b/graphics/seexpr/files/patch-src_SeExprEditor_CMakeLists.txt
new file mode 100644
index 000000000000..4e7a351d9710
--- /dev/null
+++ b/graphics/seexpr/files/patch-src_SeExprEditor_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/SeExprEditor/CMakeLists.txt.orig 2015-08-28 22:32:38 UTC
++++ src/SeExprEditor/CMakeLists.txt
+@@ -103,6 +103,8 @@ ENDIF(WIN32)
+ -t WS_X11 -g -j 1
+ -I. -I${PYQT4_SIP} -I${SIP_INCLUDE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/SeExprEditor.sip
++# libc++ 3.8.0 hack: things break if <iostream> is included after <Python.h>
++ COMMAND sed -i.bak -e "10s,^,#include <iostream>," sipAPIexpreditor.h
+ VERBATIM)
+
+ add_library(expreditor SHARED sipexpreditorpart0.cpp)