aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2016-08-30 03:27:41 +0800
committerthierry <thierry@FreeBSD.org>2016-08-30 03:27:41 +0800
commitf4bfd8c2fde57e6aaa9abb6f570be5de922999e8 (patch)
treefe46098cc8e1f64137f78ce562dd10653eee918a /graphics
parent10fa1328b1d00e86a6fd70bb7c97336666f78c49 (diff)
downloadfreebsd-ports-gnome-f4bfd8c2fde57e6aaa9abb6f570be5de922999e8.tar.gz
freebsd-ports-gnome-f4bfd8c2fde57e6aaa9abb6f570be5de922999e8.tar.zst
freebsd-ports-gnome-f4bfd8c2fde57e6aaa9abb6f570be5de922999e8.zip
Do not require GCC.
PR: 211760 Submitted by: pfg
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Coin/Makefile7
-rw-r--r--graphics/Coin/files/patch-Makefile.in6
-rw-r--r--graphics/Coin/files/patch-include-Inventor-SbBasic.h34
-rw-r--r--graphics/Coin/files/patch-include_Inventor_C_base_math-undefs.h21
-rw-r--r--graphics/Coin/pkg-descr4
5 files changed, 58 insertions, 14 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index 9bb24f46758b..f52ed813c98b 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Coin
PORTVERSION= 3.1.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/Coin3D/coin/downloads/
@@ -14,10 +14,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libsimage.so:graphics/simage
-USE_GCC= any
USES= openal:al libtool
USE_GL= yes
-USE_XORG= xt x11
+USE_XORG= ice sm x11 xext xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pthread=yes --enable-threadsafe \
--enable-3ds-import --enable-sound \
@@ -26,7 +25,7 @@ USE_LDCONFIG= yes
MAKE_ENV= LANG=C
INSTALL_TARGET= install-strip
-post-patch:
+pre-configure:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' \
${WRKSRC}/Makefile.in
@${FIND} ${WRKSRC} \( -name \*.cpp -o -name \*.h -a \! \
diff --git a/graphics/Coin/files/patch-Makefile.in b/graphics/Coin/files/patch-Makefile.in
index cddfefa40492..4c5b3a031e75 100644
--- a/graphics/Coin/files/patch-Makefile.in
+++ b/graphics/Coin/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2010-03-02 10:20:09.000000000 -0300
-+++ Makefile.in 2010-03-05 21:39:05.000000000 -0300
-@@ -1399,7 +1399,7 @@
+--- Makefile.in.orig 2010-03-02 13:20:09 UTC
++++ Makefile.in
+@@ -1399,7 +1399,7 @@ BOOST_HEADER_FILES = \
include/boost/version.hpp \
include/boost/visit_each.hpp
diff --git a/graphics/Coin/files/patch-include-Inventor-SbBasic.h b/graphics/Coin/files/patch-include-Inventor-SbBasic.h
index 05a007397909..f68b228754c6 100644
--- a/graphics/Coin/files/patch-include-Inventor-SbBasic.h
+++ b/graphics/Coin/files/patch-include-Inventor-SbBasic.h
@@ -1,10 +1,32 @@
---- include/Inventor/SbBasic.h.orig 2010-03-02 21:20:09.000000000 +0800
-+++ include/Inventor/SbBasic.h 2013-12-01 05:17:51.275860731 +0800
-@@ -25,6 +25,7 @@
- \**************************************************************************/
+--- include/Inventor/SbBasic.h.orig 2010-03-02 13:20:09 UTC
++++ include/Inventor/SbBasic.h
+@@ -88,17 +88,24 @@ inline Type SbSqr(const Type val) {
+ // warning if so for debug builds. inlined like this to not take much
+ // screenspace in inline functions.
- #include <Inventor/C/basic.h>
+-// cc_debugerror_post() is not attempted resolved before the template is
+-// used, hence the missing Inventor/errors/SoDebugError.h #include. This
+-// "trick" does only work *portably* for functions in the global namespace.
++// Missing include for cc_debugerror_post() added here. The previous "trick"
++// for not needing to resolve symbols in global namespace no longer works
++// with newer compilers.
++#ifndef NDEBUG
+#include <Inventor/C/errors/debugerror.h>
++#endif // !NDEBUG
+
++
++#ifndef NDEBUG
+ template <typename Type>
+ inline void SbDividerChk(const char * funcname, Type divider) {
+-#ifndef NDEBUG
+ if (!(divider != static_cast<Type>(0)))
+ cc_debugerror_post(funcname, "divide by zero error.", divider);
+-#endif // !NDEBUG
+ }
++#else
++template <typename Type>
++inline void SbDividerChk(const char *, Type) {}
++#endif // !NDEBUG
/* ********************************************************************** */
- /* Trap people trying to use Inventor headers while compiling C source code.
+
diff --git a/graphics/Coin/files/patch-include_Inventor_C_base_math-undefs.h b/graphics/Coin/files/patch-include_Inventor_C_base_math-undefs.h
new file mode 100644
index 000000000000..75ee7e8cd2cd
--- /dev/null
+++ b/graphics/Coin/files/patch-include_Inventor_C_base_math-undefs.h
@@ -0,0 +1,21 @@
+--- include/Inventor/C/base/math-undefs.h.orig 2016-08-29 01:17:19 UTC
++++ include/Inventor/C/base/math-undefs.h
+@@ -40,6 +40,8 @@
+ work as intended. 20070518 larsa
+ */
+
++#ifndef __clang__
++
+ #undef cosf
+ #define cosf(x) NO_SINGLEPREC /* whatever that'll give us a compile error... */
+ #undef sinf
+@@ -59,6 +61,9 @@
+ #undef atan2f
+ #define atan2f(x) NO_SINGLEPREC
+
++#endif // !__clang__
++
++
+ /* *********************************************************************** */
+
+ #endif // !COIN_MATH_UNDEFS_H
diff --git a/graphics/Coin/pkg-descr b/graphics/Coin/pkg-descr
index d9c6eb78fb33..f358529907c6 100644
--- a/graphics/Coin/pkg-descr
+++ b/graphics/Coin/pkg-descr
@@ -1,4 +1,4 @@
-From its README:
+Coin3D
Coin is a 3D graphics library with a C++ Application Programming
Interface based on the Open Inventor 2.1 API. Open Inventor, for those
@@ -7,4 +7,6 @@ scene-graph rendering and interaction library, which has become the de
facto standard graphics library for 3D visualization and visual
simulation software in the scientific and engineering community.
+New versions are published under the BSD 3-clause license.
+
WWW: https://bitbucket.org/Coin3D/coin/wiki/Home