aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2004-08-18 23:59:36 +0800
committermich <mich@FreeBSD.org>2004-08-18 23:59:36 +0800
commitf9f17e9dbded41712b7cd080c8d19e2de1d4d542 (patch)
treecddb7f90f031ec51c412cd93012e30b1311c8030 /graphics
parent7734b09f120c8b32b2233460a84c362bf461d717 (diff)
downloadfreebsd-ports-gnome-f9f17e9dbded41712b7cd080c8d19e2de1d4d542.tar.gz
freebsd-ports-gnome-f9f17e9dbded41712b7cd080c8d19e2de1d4d542.tar.zst
freebsd-ports-gnome-f9f17e9dbded41712b7cd080c8d19e2de1d4d542.zip
o Fix build with gcc 3.4.x
o Switch to REINPLACE_CMD o Tested on CURRENT-amd64 / CURRENT-i386 / 5.2.1REL-i386 Tested by mux
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tcm/Makefile4
-rw-r--r--graphics/tcm/files/patch-src_sd_dv_function.h16
2 files changed, 19 insertions, 1 deletions
diff --git a/graphics/tcm/Makefile b/graphics/tcm/Makefile
index 1ede5462e57d..dc1b4e9e5b42 100644
--- a/graphics/tcm/Makefile
+++ b/graphics/tcm/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
USE_MOTIF= yes
USE_BISON= yes
USE_GMAKE= yes
@@ -33,8 +34,9 @@ MAN1= psf.1 tatd.1 tcbd.1 tcm.1 tcmd.1 tcmdv.1 tcmt.1 tcpd.1 tcrd.1 \
post-patch:
@${RM} ${WRKSRC}/man/windex
@${CHMOD} 0644 ${WRKSRC}/lib/colorrgb.txt
+ @${REINPLACE_CMD} -e 's:gcc:g++:g' ${WRKSRC}/bin/makedepend.sh
post-install:
- @${SED} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
+ @${REINPLACE_CMD} -e 's:/usr/local:${PREFIX}:g' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/tcm/files/patch-src_sd_dv_function.h b/graphics/tcm/files/patch-src_sd_dv_function.h
new file mode 100644
index 000000000000..c9b9955ecf34
--- /dev/null
+++ b/graphics/tcm/files/patch-src_sd_dv_function.h
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- src/sd/dv/function.h.orig Wed Aug 18 16:02:05 2004
++++ src/sd/dv/function.h Wed Aug 18 16:02:38 2004
+@@ -19,8 +19,8 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ // 02111-1307, USA.
+ //-----------------------------------------------------------------------------
+-#ifndef _FUNCTION_H
+-#define _FUNCTION_H
++#ifndef _FUNCTION_CLASS_H
++#define _FUNCTION_CLASS_H
+
+ #include "c1edge.h"
+ class ERGraph;