aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-06 17:47:11 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-06 17:47:11 +0800
commitfa3cda1e36904f7b41522b844066872015908627 (patch)
treea644d501786ac30688f47644de767264ac00c084 /graphics
parent6acd0fb36adec739e8bcb8020bcd26598019cf2b (diff)
downloadfreebsd-ports-gnome-fa3cda1e36904f7b41522b844066872015908627.tar.gz
freebsd-ports-gnome-fa3cda1e36904f7b41522b844066872015908627.tar.zst
freebsd-ports-gnome-fa3cda1e36904f7b41522b844066872015908627.zip
GLFW is a free, Open Source, portable library for OpenGL and OpenGL ES
application development. It provides a simple, platform-independent API for creating windows and contexts, reading input, handling events, etc. Version 3.0 brings a new API with many new features such as multiple windows and contexts, multi-monitor support, EGL and OpenGL ES support, clipboard text support, an error description callback, gamma ramp control, layout-independent keyboard input and UTF-8 for all strings. WWW: http://www.glfw.org/ PR: ports/179605 Submitted by: nemysis (self) Approved by: wg/pawel (mentors)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/glfw-devel/Makefile67
-rw-r--r--graphics/glfw-devel/distinfo2
-rw-r--r--graphics/glfw-devel/pkg-descr10
-rw-r--r--graphics/glfw-devel/pkg-plist11
5 files changed, 91 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ada3e5f2e4b3..f67a6978ddd2 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -280,6 +280,7 @@
SUBDIR += glew
SUBDIR += glexcess
SUBDIR += glfw
+ SUBDIR += glfw-devel
SUBDIR += glide3
SUBDIR += glitz
SUBDIR += gliv
diff --git a/graphics/glfw-devel/Makefile b/graphics/glfw-devel/Makefile
new file mode 100644
index 000000000000..207aedf95c62
--- /dev/null
+++ b/graphics/glfw-devel/Makefile
@@ -0,0 +1,67 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= glfw
+PORTVERSION= 3.0.3
+CATEGORIES= graphics
+MASTER_SITES= SF
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Portable framework for OpenGL development
+
+LICENSE= ZLIB
+
+USES= cmake
+USE_XORG= xi xrandr
+USE_GL= glu
+USE_LDCONFIG= yes
+USE_GCC= 4.6+
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README.md
+
+DOCSRCDIR2= ${WRKSRC}/docs/html/search
+DOCSDIR2= ${DOCSDIR}/docs/html/search
+DOC_FILES2= *
+
+DOCSRCDIR3= ${WRKSRC}/docs/html
+DOCSDIR3= ${DOCSDIR}/docs/html
+DOC_FILES3= *.html *.png *.css *.js
+
+PORTEXAMPLES= *
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
+
+EXAMPLESSRCDIR1= ${WRKSRC}/examples
+EXAMPLES_FILES1= boing gears heightmap simple splitview wave
+
+EXAMPLESSRCDIR2= ${WRKSRC}/tests
+EXAMPLESDIR2= ${EXAMPLESDIR}/tests
+EXAMPLES_FILES2= accuracy clipboard defaults events fsaa gamma glfwinfo iconify \
+ joysticks modes peter reopen sharing tearing threads title windows
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|lib$${LIB_SUFFIX}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES3:S|^|${DOCSRCDIR3}/|} ${STAGEDIR}${DOCSDIR3}
+
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR1}/|} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR2}
+ ${INSTALL_PROGRAM} ${EXAMPLES_FILES2:S|^|${EXAMPLESSRCDIR2}/|} ${STAGEDIR}${EXAMPLESDIR2}
+
+.include <bsd.port.mk>
diff --git a/graphics/glfw-devel/distinfo b/graphics/glfw-devel/distinfo
new file mode 100644
index 000000000000..5de0e8d03b61
--- /dev/null
+++ b/graphics/glfw-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (glfw-3.0.3.tar.gz) = 51751b7a0df6e848fe941383ba9df10619be4534cb05d1bd9de03b75ac1c513d
+SIZE (glfw-3.0.3.tar.gz) = 577736
diff --git a/graphics/glfw-devel/pkg-descr b/graphics/glfw-devel/pkg-descr
new file mode 100644
index 000000000000..93bf8a4b725c
--- /dev/null
+++ b/graphics/glfw-devel/pkg-descr
@@ -0,0 +1,10 @@
+GLFW is a free, Open Source, portable library for OpenGL and OpenGL ES
+application development. It provides a simple, platform-independent API for
+creating windows and contexts, reading input, handling events, etc.
+
+Version 3.0 brings a new API with many new features such as multiple windows
+and contexts, multi-monitor support, EGL and OpenGL ES support, clipboard text
+support, an error description callback, gamma ramp control, layout-independent
+keyboard input and UTF-8 for all strings.
+
+WWW: http://www.glfw.org/
diff --git a/graphics/glfw-devel/pkg-plist b/graphics/glfw-devel/pkg-plist
new file mode 100644
index 000000000000..07e2bd275a91
--- /dev/null
+++ b/graphics/glfw-devel/pkg-plist
@@ -0,0 +1,11 @@
+include/GLFW/glfw3.h
+include/GLFW/glfw3native.h
+lib/cmake/glfw/glfwConfig.cmake
+lib/cmake/glfw/glfwConfigVersion.cmake
+lib/cmake/glfw/glfwTargets-release.cmake
+lib/cmake/glfw/glfwTargets.cmake
+lib/libglfw3.a
+libdata/pkgconfig/glfw3.pc
+@dirrm lib/cmake/glfw
+@dirrmtry lib/cmake
+@dirrm include/GLFW