aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-08-24 22:08:11 +0800
committerknu <knu@FreeBSD.org>2001-08-24 22:08:11 +0800
commitfbac1842918a028310fa12eb1babee02981623f0 (patch)
tree0c89e3e3418a052cead6cff11faefbaddda0bd6f /graphics
parent66b2bdd2747f4ca50f9541ba5c5bd78de81aa4cb (diff)
downloadfreebsd-ports-gnome-fbac1842918a028310fa12eb1babee02981623f0.tar.gz
freebsd-ports-gnome-fbac1842918a028310fa12eb1babee02981623f0.tar.zst
freebsd-ports-gnome-fbac1842918a028310fa12eb1babee02981623f0.zip
Conditionalize the dependency on bzip2.
De-portlint a bit.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gd/Makefile9
-rw-r--r--graphics/gd1/Makefile9
-rw-r--r--graphics/gd2/Makefile9
3 files changed, 18 insertions, 9 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index a6c514e9e9bd..321305c1c151 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -19,12 +19,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= ports@FreeBSD.org
-USE_FREETYPE2= yes
-BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+.if !exists(/usr/bin/bzip2)
+BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype:${PORTSDIR}/print/freetype2
+USE_FREETYPE2= yes
+
.if defined(WITH_X11)
USE_XLIB= yes
USE_XPM= yes
@@ -32,7 +35,7 @@ USE_XPM= yes
INSTALLS_SHLIB= yes
-post-extract:
+post-extract:
bzip2 -d < ${_DISTDIR}/gd_gif_in.c.bz2 > ${WRKSRC}/gd_gif_in.c
pre-everything:
diff --git a/graphics/gd1/Makefile b/graphics/gd1/Makefile
index a6c514e9e9bd..321305c1c151 100644
--- a/graphics/gd1/Makefile
+++ b/graphics/gd1/Makefile
@@ -19,12 +19,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= ports@FreeBSD.org
-USE_FREETYPE2= yes
-BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+.if !exists(/usr/bin/bzip2)
+BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype:${PORTSDIR}/print/freetype2
+USE_FREETYPE2= yes
+
.if defined(WITH_X11)
USE_XLIB= yes
USE_XPM= yes
@@ -32,7 +35,7 @@ USE_XPM= yes
INSTALLS_SHLIB= yes
-post-extract:
+post-extract:
bzip2 -d < ${_DISTDIR}/gd_gif_in.c.bz2 > ${WRKSRC}/gd_gif_in.c
pre-everything:
diff --git a/graphics/gd2/Makefile b/graphics/gd2/Makefile
index a6c514e9e9bd..321305c1c151 100644
--- a/graphics/gd2/Makefile
+++ b/graphics/gd2/Makefile
@@ -19,12 +19,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= ports@FreeBSD.org
-USE_FREETYPE2= yes
-BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+.if !exists(/usr/bin/bzip2)
+BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype:${PORTSDIR}/print/freetype2
+USE_FREETYPE2= yes
+
.if defined(WITH_X11)
USE_XLIB= yes
USE_XPM= yes
@@ -32,7 +35,7 @@ USE_XPM= yes
INSTALLS_SHLIB= yes
-post-extract:
+post-extract:
bzip2 -d < ${_DISTDIR}/gd_gif_in.c.bz2 > ${WRKSRC}/gd_gif_in.c
pre-everything: