aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-10-02 23:11:54 +0800
committerkwm <kwm@FreeBSD.org>2013-10-02 23:11:54 +0800
commit00748f8d66474dbbe8392fac796143099da9c80f (patch)
tree6fe01a24530be387869c9e94c29d8726e8a05d62 /graphics
parent2df4a5a2889831a2b97a2b3c08f1ab6bf4cf0311 (diff)
downloadfreebsd-ports-gnome-00748f8d66474dbbe8392fac796143099da9c80f.tar.gz
freebsd-ports-gnome-00748f8d66474dbbe8392fac796143099da9c80f.tar.zst
freebsd-ports-gnome-00748f8d66474dbbe8392fac796143099da9c80f.zip
Add python cairo 1.10.0 for python 3.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py3-cairo/Makefile37
-rw-r--r--graphics/py3-cairo/distinfo2
-rw-r--r--graphics/py3-cairo/files/patch-test_examples-test.py11
-rw-r--r--graphics/py3-cairo/pkg-descr3
-rw-r--r--graphics/py3-cairo/pkg-plist8
6 files changed, 62 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index dde21120b2bd..03bfff5abcdc 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -870,6 +870,7 @@
SUBDIR += py-stl
SUBDIR += py-wand
SUBDIR += py-webcolors
+ SUBDIR += py3-cairo
SUBDIR += pygts
SUBDIR += pymorph
SUBDIR += pyro
diff --git a/graphics/py3-cairo/Makefile b/graphics/py3-cairo/Makefile
new file mode 100644
index 000000000000..1da30a3ff977
--- /dev/null
+++ b/graphics/py3-cairo/Makefile
@@ -0,0 +1,37 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/graphics/py-cairo/Makefile,v 1.28 2010/11/15 14:12:13 kwm Exp $
+
+PORTNAME= cairo
+PORTVERSION= 1.10.0
+CATEGORIES= graphics python
+MASTER_SITES= http://cairographics.org/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python 3 bindings for Cairo
+
+USE_BZIP2= yes
+USE_PYTHON= 3
+USES= pkgconfig shebangfix
+USE_GNOME= cairo
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= PYTHON=${LOCALBASE}/bin/python3 \
+ PREFIX=${STAGEDIR}${PREFIX}
+
+python_OLD_CMD?= /usr/bin/env python
+python_CMD?= ${LOCALBASE}/bin/python3
+SHEBANG_FILES= examples/*.py examples/*/*.py waf test/*.py
+
+do-configure:
+ @cd ${WRKSRC} && ${ENV} ${CONFIGURE_ENV} ./waf configure
+
+do-build:
+ @cd ${WRKSRC} && ./waf
+
+do-install:
+ @cd ${WRKSRC} && ./waf install
+
+.include <bsd.port.mk>
diff --git a/graphics/py3-cairo/distinfo b/graphics/py3-cairo/distinfo
new file mode 100644
index 000000000000..2112ba175f59
--- /dev/null
+++ b/graphics/py3-cairo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pycairo-1.10.0.tar.bz2) = 9aa4078e7eb5be583aeabbe8d87172797717f95e8c4338f0d4a17b683a7253be
+SIZE (pycairo-1.10.0.tar.bz2) = 246556
diff --git a/graphics/py3-cairo/files/patch-test_examples-test.py b/graphics/py3-cairo/files/patch-test_examples-test.py
new file mode 100644
index 000000000000..fd665812a2a2
--- /dev/null
+++ b/graphics/py3-cairo/files/patch-test_examples-test.py
@@ -0,0 +1,11 @@
+--- test/examples_test.py.orig 2013-09-30 22:50:22.000000000 +0200
++++ test/examples_test.py 2013-09-30 22:50:39.000000000 +0200
+@@ -18,7 +18,7 @@
+ examples/cairo_snippets/snippets/
+ '''
+ def doSnippets(name):
+- retcode = subprocess.call('python %s -s' % name, shell=True)
++ retcode = subprocess.call('python2 %s -s' % name, shell=True)
+ assert retcode == 0, 'Error: retcode == {0}'.format(retcode)
+
+ os.chdir(os.path.join(os.path.dirname(__file__), '..', 'examples',
diff --git a/graphics/py3-cairo/pkg-descr b/graphics/py3-cairo/pkg-descr
new file mode 100644
index 000000000000..5ad843bf2da9
--- /dev/null
+++ b/graphics/py3-cairo/pkg-descr
@@ -0,0 +1,3 @@
+Python 3 bindings for Cairo.
+
+WWW: http://cairographics.org/
diff --git a/graphics/py3-cairo/pkg-plist b/graphics/py3-cairo/pkg-plist
new file mode 100644
index 000000000000..40d9076f26ea
--- /dev/null
+++ b/graphics/py3-cairo/pkg-plist
@@ -0,0 +1,8 @@
+include/pycairo/py3cairo.h
+%%PYTHON_SITELIBDIR%%/cairo/__init__.py
+%%PYTHON_SITELIBDIR%%/cairo/__init__.pyc
+%%PYTHON_SITELIBDIR%%/cairo/__init__.pyo
+%%PYTHON_SITELIBDIR%%/cairo/_cairo.so
+libdata/pkgconfig/py3cairo.pc
+@dirrm %%PYTHON_SITELIBDIR%%/cairo
+@dirrmtry include/pycairo