aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-03-03 05:32:51 +0800
committerswills <swills@FreeBSD.org>2013-03-03 05:32:51 +0800
commit00a615b4c85e93d5ab7e7cf4bdc1f8c77a65150d (patch)
tree1d0348accd512e5829caf12a3a08a5ea3872830d /graphics
parent753496fc3af61adc934d07bb3af39a564a4faf70 (diff)
downloadfreebsd-ports-gnome-00a615b4c85e93d5ab7e7cf4bdc1f8c77a65150d.tar.gz
freebsd-ports-gnome-00a615b4c85e93d5ab7e7cf4bdc1f8c77a65150d.tar.zst
freebsd-ports-gnome-00a615b4c85e93d5ab7e7cf4bdc1f8c77a65150d.zip
- Fix logic error which caused the gallium-intel driver to be always disabled [1]
- Make it possible to choose which DRI drivers will be built [2] PR: ports/174725 [1] PR: ports/154651 [2] Submitted by: John Marino <draco@marino.st> [1] Submitted by: bf [2] Reviewed by: kwm [2]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri/Makefile45
-rw-r--r--graphics/libGL/Makefile10
-rw-r--r--graphics/libGLU/Makefile10
-rw-r--r--graphics/libGLw/Makefile10
4 files changed, 47 insertions, 28 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index c4c23d84ee7a..e304186d02b6 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: dri
-# Date created: 8 Nov 2003
-# Whom: anholt@FreeBSD.org
-#
+# Created by: anholt@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= dri
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= graphics
@@ -19,6 +15,28 @@ LIB_DEPENDS= drm:${PORTSDIR}/graphics/libdrm \
USE_PKGCONFIG= build
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
+OPTIONS_DEFINE= I810 I915 I965 MACH64 MGA R128 R200 R300 R600 RADEON \
+ SAVAGE SIS SWRAST TDFX UNICHROME
+
+OPTIONS_DEFAULT=I810 I915 I965 MACH64 MGA R128 R200 R300 R600 RADEON \
+ SAVAGE SIS SWRAST TDFX UNICHROME
+
+I810_DESC= Include DRI support for Intel i810
+I915_DESC= Include DRI support for Intel i915
+I965_DESC= Include DRI support for Intel i965
+MACH64_DESC= Include DRI support for AMD/ATI Mach64
+MGA_DESC= Include DRI support for Matrox
+R128_DESC= Include DRI support for AMD/ATI R128
+R200_DESC= Include DRI support for AMD/ATI R200
+R300_DESC= Include DRI support for AMD/ATI R300
+R600_DESC= Include DRI support for AMD/ATI R600
+RADEON_DESC= Include DRI support for AMD/ATI R100
+SAVAGE_DESC= Include DRI support for S3/Via Savage
+SIS_DESC= Include DRI support for SiS 300 and 6326
+SWRAST_DESC= Include generic software DRI support
+TDFX_DESC= Include DRI support for 3dfx Voodoo
+UNICHROME_DESC= Include DRI support for S3/Via Unichrome
+
do-install:
cd ${WRKSRC}/src/mesa; ${GMAKE} install-dri
@@ -30,7 +48,7 @@ do-install:
BROKEN= Does not install on ia64
.endif
-.if ${ARCH} != "amd64" || ${ARCH} != "i386"
+.if !(${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+=--disable-gallium-intel
.endif
@@ -118,4 +136,17 @@ PLIST_SUB+= TDFX_DRIVER="@comment "
PLIST_SUB+= UNICHROME_DRIVER="@comment "
.endif
+ALL_DRI_DRIVERS= i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ savage sis swrast tdfx unichrome
+
+.for _d in ${ALL_DRI_DRIVERS}
+.if ${PORT_OPTIONS:M${_d:U}}
+DRI_DRIVERS+= ,${_d}
+PLIST_SUB+= ${_d:U}=""
+. else
+PLIST_SUB+= ${_d:U}="@comment "
+. endif
+.endfor
+CONFIGURE_ARGS+= --with-dri-drivers="${DRI_DRIVERS:C/,//1}"
+
.include <bsd.port.post.mk>
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 1df7ef1c4234..64d621092ef8 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: xorg-server
-# Date created: 7 May 2004
-# Whom: anholt@FreeBSD.org
-#
+# Created by: anholt@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= libGL
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
COMMENT= OpenGL library that renders using GLX or DRI
@@ -31,7 +27,7 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} != "amd64" || ${ARCH} != "i386"
+.if !(${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+=--disable-gallium-intel
.endif
diff --git a/graphics/libGLU/Makefile b/graphics/libGLU/Makefile
index 4655e4d33d5d..0acf73692cab 100644
--- a/graphics/libGLU/Makefile
+++ b/graphics/libGLU/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: libGLU
-# Date created: 7 May 2004
-# Whom: anholt@FreeBSD.org
-#
+# Created by: anholt@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= libGLU
-PORTREVISION= 1
+PORTREVISION= 2
PORTVERSION= ${MESAVERSION}
CATEGORIES= graphics
@@ -25,7 +21,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} != "amd64" || ${ARCH} != "i386"
+.if !(${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+=--disable-gallium-intel
.endif
diff --git a/graphics/libGLw/Makefile b/graphics/libGLw/Makefile
index e7d60afeeab2..bee681133ace 100644
--- a/graphics/libGLw/Makefile
+++ b/graphics/libGLw/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: libGLw
-# Date created: 7 May 2004
-# Whom: anholt@FreeBSD.org
-#
+# Created by: anholt@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= libGLw
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
COMMENT= OpenGL widgets library
@@ -23,7 +19,7 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} != "amd64" || ${ARCH} != "i386"
+.if !(${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+=--disable-gallium-intel
.endif