aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-09-28 01:17:49 +0800
committerwg <wg@FreeBSD.org>2014-09-28 01:17:49 +0800
commit02f450175b238e126893a7108eeea226acbb72cd (patch)
tree4d66c7d11ebeb52807426e4a4c8e8f0e0ae35887 /graphics
parent56be746ae4cabb8f94dab86f64efd69714a5c65b (diff)
downloadfreebsd-ports-gnome-02f450175b238e126893a7108eeea226acbb72cd.tar.gz
freebsd-ports-gnome-02f450175b238e126893a7108eeea226acbb72cd.tar.zst
freebsd-ports-gnome-02f450175b238e126893a7108eeea226acbb72cd.zip
graphics/py-pivy: Python binding for Coin
Pivy is a Coin binding for Python. Coin is a high-level 3D graphics library with a C++ Application Programming Interface. Coin uses scene-graph data structures to render real-time graphics suitable for mostly all kinds of scientific and engineering visualization applications. WWW: https://pypi.python.org/pypi/Pivy PR: 193684 Submitted by: pfg
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pivy/Makefile23
-rw-r--r--graphics/py-pivy/distinfo2
-rw-r--r--graphics/py-pivy/pkg-descr8
4 files changed, 34 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4673f112f18a..64c710d56563 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -847,6 +847,7 @@
SUBDIR += py-openimageio
SUBDIR += py-paint
SUBDIR += py-pillow
+ SUBDIR += py-pivy
SUBDIR += py-png
SUBDIR += py-poppler
SUBDIR += py-poppler-qt4
diff --git a/graphics/py-pivy/Makefile b/graphics/py-pivy/Makefile
new file mode 100644
index 000000000000..bd6885b3df11
--- /dev/null
+++ b/graphics/py-pivy/Makefile
@@ -0,0 +1,23 @@
+# Created by: Pedro Giffuni <pfg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pivy
+PORTVERSION= 0.5.0
+CATEGORIES= graphics python
+MASTER_SITES= https://bitbucket.org/Coin3D/pivy/get/
+DISTNAME= 8eab90908f2a
+
+MAINTAINER= pfg@FreeBSD.org
+COMMENT= Python binding for Coin
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= libSoQt.so:${PORTSDIR}/x11-toolkits/soqt
+
+USES= zip python:2
+USE_PYTHON= autoplist distutils
+
+WRKSRC= ${WRKDIR}/Coin3D-pivy-${DISTNAME}
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pivy/distinfo b/graphics/py-pivy/distinfo
new file mode 100644
index 000000000000..21017f6df0d3
--- /dev/null
+++ b/graphics/py-pivy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (8eab90908f2a.zip) = 045da82a84463fe1cfecf90c5fb6c04fe47be0647be69c8225e16364d9dc249a
+SIZE (8eab90908f2a.zip) = 7029165
diff --git a/graphics/py-pivy/pkg-descr b/graphics/py-pivy/pkg-descr
new file mode 100644
index 000000000000..eac4237009df
--- /dev/null
+++ b/graphics/py-pivy/pkg-descr
@@ -0,0 +1,8 @@
+A Python binding for Coin
+
+Pivy is a Coin binding for Python. Coin is a high-level 3D graphics library
+with a C++ Application Programming Interface. Coin uses scene-graph data
+structures to render real-time graphics suitable for mostly all kinds of
+scientific and engineering visualization applications.
+
+WWW: https://pypi.python.org/pypi/Pivy