aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-05-10 04:24:29 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-05-10 04:24:29 +0800
commit06d9081a87be120d30dd6ea9a21ec63d67fe2909 (patch)
treefca55a35d0fc36d58353ea48d2605046a7e3af7b /graphics
parent590bb871309ca55b55a24c1425159f66b36e1f76 (diff)
downloadfreebsd-ports-gnome-06d9081a87be120d30dd6ea9a21ec63d67fe2909.tar.gz
freebsd-ports-gnome-06d9081a87be120d30dd6ea9a21ec63d67fe2909.tar.zst
freebsd-ports-gnome-06d9081a87be120d30dd6ea9a21ec63d67fe2909.zip
Add l2p 1.0, which creates PNG images from LaTeX math expressions.
PR: 94847 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/l2p/Makefile44
-rw-r--r--graphics/l2p/distinfo3
-rw-r--r--graphics/l2p/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 529e842ffe68..c6ccc2746f4d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -291,6 +291,7 @@
SUBDIR += kphotoalbum
SUBDIR += kudu
SUBDIR += kuickshow
+ SUBDIR += l2p
SUBDIR += landscape
SUBDIR += lcms
SUBDIR += leafpak
diff --git a/graphics/l2p/Makefile b/graphics/l2p/Makefile
new file mode 100644
index 000000000000..0815981120e7
--- /dev/null
+++ b/graphics/l2p/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: l2p
+# Date created: 2006-03-22
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= l2p
+PORTVERSION= 1.0
+CATEGORIES= graphics print perl5
+MASTER_SITES= http://www.redsymbol.net/software/l2p/dist/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-latest
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= Create PNG images from LaTeX math expressions
+
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ dvips:${PORTSDIR}/print/dvipsk-tetex \
+ latex:${PORTSDIR}/print/teTeX
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/l2p
+PORTDOCS= l2p.txt l2p.html
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/l2p/distinfo b/graphics/l2p/distinfo
new file mode 100644
index 000000000000..068ed806da4d
--- /dev/null
+++ b/graphics/l2p/distinfo
@@ -0,0 +1,3 @@
+MD5 (l2p/1.0/l2p-latest.tgz) = 87db2e0b5e6b8fffbeb1137a24c343b2
+SHA256 (l2p/1.0/l2p-latest.tgz) = 48238fb9c2dbc4679bb475e57182bcbaf5cad057632572d48bd008816d7edc60
+SIZE (l2p/1.0/l2p-latest.tgz) = 7540
diff --git a/graphics/l2p/pkg-descr b/graphics/l2p/pkg-descr
new file mode 100644
index 000000000000..c27d395b72e6
--- /dev/null
+++ b/graphics/l2p/pkg-descr
@@ -0,0 +1,4 @@
+A command-line program to create PNG images from LaTeX math expressions.
+
+Author: Aaron Maxwell <amax@redsymbol.net>
+WWW: http://www.redsymbol.net/software/l2p/