aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-17 07:51:43 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-17 07:51:43 +0800
commit0ddcee7923a83bab98fa7ab6f9da00295d078947 (patch)
tree681e49bdc2f6718d273e5eb6a3e58f75bb4bcd7a /graphics
parentc6a1807ce3d6c2e78c7f0f795e16ad4a6107efd3 (diff)
downloadfreebsd-ports-gnome-0ddcee7923a83bab98fa7ab6f9da00295d078947.tar.gz
freebsd-ports-gnome-0ddcee7923a83bab98fa7ab6f9da00295d078947.tar.zst
freebsd-ports-gnome-0ddcee7923a83bab98fa7ab6f9da00295d078947.zip
- Support staging
- Use new LIB_DEPENDS syntax
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autopano-sift-c/Makefile21
-rw-r--r--graphics/autopano-sift-c/pkg-plist8
2 files changed, 14 insertions, 15 deletions
diff --git a/graphics/autopano-sift-c/Makefile b/graphics/autopano-sift-c/Makefile
index 32904b9db095..1872c200c846 100644
--- a/graphics/autopano-sift-c/Makefile
+++ b/graphics/autopano-sift-c/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= SF/hugin/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Automatic panorama control point generation tool, C port
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- pano13:${PORTSDIR}/graphics/libpano13
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libpano13.so:${PORTSDIR}/graphics/libpano13
RESTRICTED= May be covered by patents
@@ -22,24 +22,15 @@ CONFLICTS= autopano-sift-[0-9]*
USE_GNOME= libxml2
USES= cmake
-PLIST_FILES= bin/autopano bin/autopano-c-complete.sh \
- bin/autopano-sift-c bin/generatekeys
-
PORTDOCS= *
-MAN1= autopano-c-complete.1 autopano.1 generatekeys.1
-MAN7= autopano-sift-c.7
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.1ST ${DOCSDIR}/
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.1ST ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/graphics/autopano-sift-c/pkg-plist b/graphics/autopano-sift-c/pkg-plist
new file mode 100644
index 000000000000..3393ebab93bd
--- /dev/null
+++ b/graphics/autopano-sift-c/pkg-plist
@@ -0,0 +1,8 @@
+bin/autopano
+bin/autopano-c-complete.sh
+bin/autopano-sift-c
+bin/generatekeys
+man/man1/autopano-c-complete.1.gz
+man/man1/autopano.1.gz
+man/man1/generatekeys.1.gz
+man/man7/autopano-sift-c.7.gz