aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-14 09:33:55 +0800
committermaho <maho@FreeBSD.org>2007-07-14 09:33:55 +0800
commit145515c3cac46439c24c5e1009b5271d1aad9141 (patch)
tree88982fdc79c56289cf7c74a739ab938f09cd4b34 /graphics
parentc8207a4a04a94b6234eaf891fe1ba2795035c0ea (diff)
downloadfreebsd-ports-gnome-145515c3cac46439c24c5e1009b5271d1aad9141.tar.gz
freebsd-ports-gnome-145515c3cac46439c24c5e1009b5271d1aad9141.tar.zst
freebsd-ports-gnome-145515c3cac46439c24c5e1009b5271d1aad9141.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Approved by: thierry
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cimg/Makefile5
-rw-r--r--graphics/xd3d/Makefile5
2 files changed, 2 insertions, 8 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index cdcb8299afea..2e6cf6b3d575 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -33,10 +33,7 @@ LAPACK_LIB= -L${LOCALBASE}/lib -lalapack -lcblas -lf77blas -L`${CAT} ${WRKSRC}/L
LAPACK_DEF= -Dcimg_lapack
. endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
. if !defined(WITHOUT_OPTIMIZATIONS)
USE_XLIB= yes
diff --git a/graphics/xd3d/Makefile b/graphics/xd3d/Makefile
index e24e199f6e6d..0f4eda809687 100644
--- a/graphics/xd3d/Makefile
+++ b/graphics/xd3d/Makefile
@@ -42,10 +42,7 @@ REINPLACE_ARGS= -i ""
FETCH_CMD= /usr/bin/fetch
FETCH_BEFORE_ARGS= -R -o ${DISTDIR}/${DISTFILES}
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FFLAGS+= -O
MEMORY_XD3D?= 64