aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2012-11-24 10:25:38 +0800
committerfluffy <fluffy@FreeBSD.org>2012-11-24 10:25:38 +0800
commit166bebc861f629af428d526bfa3291a06de0c751 (patch)
treec784199445108560fa73bd5ab3244125442a7b3f /graphics
parent1fb7e8e98a31f2a06d5def78f312b3c77f067e8c (diff)
downloadfreebsd-ports-gnome-166bebc861f629af428d526bfa3291a06de0c751.tar.gz
freebsd-ports-gnome-166bebc861f629af428d526bfa3291a06de0c751.tar.zst
freebsd-ports-gnome-166bebc861f629af428d526bfa3291a06de0c751.zip
- Force to use gcc46+ if CC is not Clang.
Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/vigra/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index fd321879f826..11f2f7c2b1c9 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -56,6 +56,12 @@ PLIST_SUB+= PYTHON="@comment "
.include <bsd.port.pre.mk>
+# Check for clang, else use gcc46+
+CPP_check!= ${CPP} --version | tr -d '()'
+.if !${CPP_check:Mclang}
+USE_GCC= 4.6+
+.endif
+
# Vigra's CMakeLists.txt does not support disabling those so we hook them
# as dependencies here unconditionally (without OPTIONS=) even though if
# they are not present then Vigra/CMake will do without them (they are not