aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-02-24 08:23:52 +0800
committerpawel <pawel@FreeBSD.org>2013-02-24 08:23:52 +0800
commit2a194ff4772eecaa07019517d2044e0ffc09ddbd (patch)
treedae6cc6ace9e6a3d7ece6efe4de7d971877a5933 /graphics
parentc396c869264abcd305727963d8647c67190e860e (diff)
downloadfreebsd-ports-gnome-2a194ff4772eecaa07019517d2044e0ffc09ddbd.tar.gz
freebsd-ports-gnome-2a194ff4772eecaa07019517d2044e0ffc09ddbd.tar.zst
freebsd-ports-gnome-2a194ff4772eecaa07019517d2044e0ffc09ddbd.zip
- Update to version 0.9.2
- Remove ABI versions from LIB_DEPENDS - Fix WWW line in pkg-descr - Take maintainership
Diffstat (limited to 'graphics')
-rw-r--r--graphics/podofo/Makefile25
-rw-r--r--graphics/podofo/distinfo4
-rw-r--r--graphics/podofo/pkg-descr2
-rw-r--r--graphics/podofo/pkg-plist3
4 files changed, 17 insertions, 17 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 09064a9b09f6..f8b01b70bae9 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -1,24 +1,20 @@
-# New ports collection makefile for: podofo
-# Date created: 10/17/2009
-# Whom: stas
-#
+# Created by: stas
# $FreeBSD$
-#
PORTNAME= podofo
-PORTVERSION= 0.9.1
-PORTREVISION= 3
+PORTVERSION= 0.9.2
CATEGORIES= graphics print
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pawel@FreeBSD.org
COMMENT= PDF manipulation library and tools
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
+ freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
OPTIONS_DEFINE= JPEG TIFF PNG IMPOSE
OPTIONS_DEFAULT= JPEG TIFF PNG
@@ -26,8 +22,11 @@ IMPOSE_DESC= Build impose tool (needs Lua)
USE_CMAKE= yes
CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
- -DPODOFO_BUILD_STATIC:BOOL=FALSE
+ -DPODOFO_BUILD_STATIC:BOOL=FALSE \
+ -DOPENSSL_INCLUDE_DIR:PATH="${OPENSSLINC}" \
+ -DOPENSSL_LIBRARIES:PATH="${OPENSSLDIR}"
USE_GCC= any
+USE_OPENSSL= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
@@ -40,12 +39,12 @@ MAN1= podofobox.1 podofocountpages.1 podofocrop.1 \
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
CMAKE_ARGS+= -DWANT_LIBJPEG:BOOL=TRUE
.endif
.if ${PORT_OPTIONS:MTIFF}
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
CMAKE_ARGS+= -DWANT_TIFF:BOOL=TRUE
.endif
diff --git a/graphics/podofo/distinfo b/graphics/podofo/distinfo
index 8c9de7280b05..9957ada73600 100644
--- a/graphics/podofo/distinfo
+++ b/graphics/podofo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (podofo-0.9.1.tar.gz) = 7b969de0b6c584358f26fc5de23cff0378f46023e678fe058efbb64003ec9745
-SIZE (podofo-0.9.1.tar.gz) = 1080079
+SHA256 (podofo-0.9.2.tar.gz) = 465191618c57da9ae9230e7919e1985a242ddc7d1045cfdb6fb066140ed0a3f3
+SIZE (podofo-0.9.2.tar.gz) = 1092131
diff --git a/graphics/podofo/pkg-descr b/graphics/podofo/pkg-descr
index ca3f97cf5fbe..ca311e73f70f 100644
--- a/graphics/podofo/pkg-descr
+++ b/graphics/podofo/pkg-descr
@@ -2,4 +2,4 @@ PoDoFo is a library to work with the PDF file format. The name comes
from the first letter of PDF (Portable Document Format). A few tools
to work with PDF files are already included in the PoDoFo package.
-WWW: http://podofo.sourceforge.net
+WWW: http://podofo.sourceforge.net
diff --git a/graphics/podofo/pkg-plist b/graphics/podofo/pkg-plist
index aa483ddea87c..817324008141 100644
--- a/graphics/podofo/pkg-plist
+++ b/graphics/podofo/pkg-plist
@@ -52,7 +52,6 @@ include/podofo/base/PdfRect.h
include/podofo/base/PdfRefCountedBuffer.h
include/podofo/base/PdfRefCountedInputDevice.h
include/podofo/base/PdfReference.h
-include/podofo/base/PdfRijndael.h
include/podofo/base/PdfStream.h
include/podofo/base/PdfString.h
include/podofo/base/PdfTokenizer.h
@@ -73,6 +72,7 @@ include/podofo/base/util/PdfMutexWrapper.h
include/podofo/doc/PdfAcroForm.h
include/podofo/doc/PdfAction.h
include/podofo/doc/PdfAnnotation.h
+include/podofo/doc/PdfCMapEncoding.h
include/podofo/doc/PdfContents.h
include/podofo/doc/PdfDestination.h
include/podofo/doc/PdfDifferenceEncoding.h
@@ -85,6 +85,7 @@ include/podofo/doc/PdfFileSpec.h
include/podofo/doc/PdfFont.h
include/podofo/doc/PdfFontCID.h
include/podofo/doc/PdfFontCache.h
+include/podofo/doc/PdfFontConfigWrapper.h
include/podofo/doc/PdfFontFactory.h
include/podofo/doc/PdfFontFactoryBase14Data.h
include/podofo/doc/PdfFontMetrics.h