aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-04-27 20:07:36 +0800
committerkwm <kwm@FreeBSD.org>2015-04-27 20:07:36 +0800
commit2d767d60b504a7a9b7ae24610e61f5b70ec47098 (patch)
treeb5e2e56d4cd4a31b74b66614d7a926018844faf1 /graphics
parent582f712392970789bc2bfd77282874de6b4f5dac (diff)
downloadfreebsd-ports-gnome-2d767d60b504a7a9b7ae24610e61f5b70ec47098.tar.gz
freebsd-ports-gnome-2d767d60b504a7a9b7ae24610e61f5b70ec47098.tar.zst
freebsd-ports-gnome-2d767d60b504a7a9b7ae24610e61f5b70ec47098.zip
I'm not sure what the code exactly does but reverting the change allows it
to build on 8.x. Submitted by: Scott Allendorf <scott-allendorf@uiowa.edu>, pkg-fallout.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile4
-rw-r--r--graphics/ImageMagick/files/extra-magick_locale.c98
2 files changed, 102 insertions, 0 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index c962f08c3fcc..8719136dbb02 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -379,6 +379,10 @@ INSTALL_TARGET= install-strip
USE_GHOSTSCRIPT_BUILD=yes
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
+EXTRA_PATCHES+= ${FILESDIR}/extra-magick_locale.c
+.endif
+
post-patch:
# strip library name of variable parts that can change due to
# the HDRI and Q16 option
diff --git a/graphics/ImageMagick/files/extra-magick_locale.c b/graphics/ImageMagick/files/extra-magick_locale.c
new file mode 100644
index 000000000000..ba12452fbd6b
--- /dev/null
+++ b/graphics/ImageMagick/files/extra-magick_locale.c
@@ -0,0 +1,98 @@
+--- magick/locale.c.orig 2015-04-14 23:09:38.000000000 +0200
++++ magick/locale.c 2015-04-27 12:00:08.997474000 +0200
+@@ -66,6 +66,14 @@
+ #define MaxRecursionDepth 200
+
+ /*
++ Typedef declarations.
++*/
++#if defined(__CYGWIN__)
++typedef struct _locale_t
++ *locale_t;
++#endif
++
++/*
+ Static declarations.
+ */
+ static const char
+@@ -86,7 +94,7 @@ static SemaphoreInfo
+ static SplayTreeInfo
+ *locale_cache = (SplayTreeInfo *) NULL;
+
+-#if defined(MAGICKCORE_HAVE_LOCALE_H)
++#if defined(MAGICKCORE_HAVE_STRTOD_L)
+ static volatile locale_t
+ c_locale = (locale_t) NULL;
+ #endif
+@@ -99,7 +107,7 @@ static MagickBooleanType
+ LoadLocaleCache(SplayTreeInfo *,const char *,const char *,const char *,
+ const size_t,ExceptionInfo *);
+
+-#if defined(MAGICKCORE_HAVE_LOCALE_H)
++#if defined(MAGICKCORE_HAVE_STRTOD_L)
+ /*
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
+ % %
+@@ -229,7 +237,7 @@ static SplayTreeInfo *AcquireLocaleSplay
+ return(locale_cache);
+ }
+
+-#if defined(MAGICKCORE_HAVE_LOCALE_H)
++#if defined(MAGICKCORE_HAVE_STRTOD_L)
+ /*
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
+ % %
+@@ -331,7 +339,7 @@ MagickExport ssize_t FormatLocaleFileLis
+ ssize_t
+ n;
+
+-#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_VFPRINTF_L)
++#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
+ {
+ locale_t
+ locale;
+@@ -347,7 +355,7 @@ MagickExport ssize_t FormatLocaleFileLis
+ #endif
+ }
+ #else
+-#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_USELOCALE)
++#if defined(MAGICKCORE_HAVE_USELOCALE) && defined(MAGICKCORE_HAVE_STRTOD_L)
+ {
+ locale_t
+ locale,
+@@ -422,7 +430,7 @@ MagickExport ssize_t FormatLocaleStringL
+ ssize_t
+ n;
+
+-#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_VSNPRINTF_L)
++#if defined(MAGICKCORE_HAVE_VSNPRINTF_L)
+ {
+ locale_t
+ locale;
+@@ -438,7 +446,7 @@ MagickExport ssize_t FormatLocaleStringL
+ #endif
+ }
+ #elif defined(MAGICKCORE_HAVE_VSNPRINTF)
+-#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_USELOCALE)
++#if defined(MAGICKCORE_HAVE_USELOCALE) && defined(MAGICKCORE_HAVE_STRTOD_L)
+ {
+ locale_t
+ locale,
+@@ -981,7 +989,7 @@ MagickExport double InterpretLocaleValue
+ value=(double) strtoul(string,&q,16);
+ else
+ {
+-#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_STRTOD_L)
++#if defined(MAGICKCORE_HAVE_STRTOD_L)
+ locale_t
+ locale;
+
+@@ -1420,7 +1428,7 @@ MagickExport void LocaleComponentTerminu
+ LockSemaphoreInfo(locale_semaphore);
+ if (locale_cache != (SplayTreeInfo *) NULL)
+ locale_cache=DestroySplayTree(locale_cache);
+-#if defined(MAGICKCORE_HAVE_LOCALE_H)
++#if defined(MAGICKCORE_HAVE_STRTOD_L)
+ DestroyCLocale();
+ #endif
+ UnlockSemaphoreInfo(locale_semaphore);