aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-02-12 05:40:39 +0800
committerthierry <thierry@FreeBSD.org>2006-02-12 05:40:39 +0800
commit35438d4d9624645d12cf65d0d5009b3dbaa87d0e (patch)
treee429b7272842b5d797be199065875fd4ca2fadaa /graphics
parent9c238328189f8ceb4ffa5ae39fb066015d461deb (diff)
downloadfreebsd-ports-gnome-35438d4d9624645d12cf65d0d5009b3dbaa87d0e.tar.gz
freebsd-ports-gnome-35438d4d9624645d12cf65d0d5009b3dbaa87d0e.tar.zst
freebsd-ports-gnome-35438d4d9624645d12cf65d0d5009b3dbaa87d0e.zip
Attempt to fix on amd64.
Submitted by: Igor Pokrovsky <ip (at) doom.homeunix.org> (maintainer) Reported by: pointyhat via Kris
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gephex/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/gephex/Makefile b/graphics/gephex/Makefile
index d7c1f9639dca..0d06a0af1e2b 100644
--- a/graphics/gephex/Makefile
+++ b/graphics/gephex/Makefile
@@ -24,7 +24,6 @@ CONFIGURE_ARGS= --without-V4L --without-ASOUNDLIB --without-LINUX_JOYSTICK \
--without-FFMPEG --without-AVIFILE --without-MPEG3 \
--without-LIBPNG --without-SDL --without-SDL_IMAGE \
--without-SDL_TTF --without-AALIB --disable-static
-CONFIGURE_ENV= "CFLAGS+=-I${LOCALBASE}/include LDFLAGS+=-L${LOCALBASE}/lib"
USE_QT_VER= 3
WANT_SDL= yes
INSTALLS_SHLIB= yes
@@ -172,4 +171,11 @@ post-patch:
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_DOCS}|' ${WRKSRC}/Makefile.am
+# Compile contents of static libs with PIC, as they can be used in dynamic ones
+.if !empty(ARCH:M*64)
+ @(${FIND} -X ${WRKSRC} -name Makefile.am \! -regex '.*cpuinfo.*' | \
+ ${XARGS} ${REINPLACE_CMD} -E -e \
+ "/^lib[[:alnum:]]+_a_SOURCES.*$$/{ h; s//AM_CFLAGS = -DPIC -fPIC/; G;}")
+.endif
+
.include <bsd.port.post.mk>