aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-11-16 04:01:45 +0800
committermi <mi@FreeBSD.org>2004-11-16 04:01:45 +0800
commit3a5a8a665c41500494b0e7c8f9ad2f2a91cea5d8 (patch)
tree8ae994fcea39d7d4328bc5c574d076810c871aa1 /graphics
parent6753b9aa3637ede68149c6b5790b28ed51732de2 (diff)
downloadfreebsd-ports-gnome-3a5a8a665c41500494b0e7c8f9ad2f2a91cea5d8.tar.gz
freebsd-ports-gnome-3a5a8a665c41500494b0e7c8f9ad2f2a91cea5d8.tar.zst
freebsd-ports-gnome-3a5a8a665c41500494b0e7c8f9ad2f2a91cea5d8.zip
Add a patch fixing a double/float pointer mismatch. Bump PORTREVISION.
PR: ports/73811 Approved by: dinoex (maintainer) Submitted by: Peter Fales (to TIFF mailing list)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tiff/Makefile1
-rw-r--r--graphics/tiff/files/patch-float9
2 files changed, 10 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index b68f2ea08a24..6eb57c66f858 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -9,6 +9,7 @@
PORTNAME= tiff
PORTVERSION= 3.7.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://dl1.maptools.org/dl/libtiff/
diff --git a/graphics/tiff/files/patch-float b/graphics/tiff/files/patch-float
new file mode 100644
index 000000000000..c95ec8069ac7
--- /dev/null
+++ b/graphics/tiff/files/patch-float
@@ -0,0 +1,9 @@
+--- tools/tiff2ps.c Thu Oct 14 13:53:28 2004
++++ tools/tiff2ps.c Mon Nov 15 10:05:30 2004
+@@ -412,5 +412,5 @@
+ setupPageState(TIFF* tif, uint32* pw, uint32* ph, double* pprw, double* pprh)
+ {
+- double xres = 0.0, yres = 0.0;
++ float xres = 0.0, yres = 0.0;
+
+ TIFFGetField(tif, TIFFTAG_IMAGEWIDTH, pw);