aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-22 14:03:40 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-22 14:03:40 +0800
commit402f473319dd6ff40a5d93416e6b0fb7cbdd76e3 (patch)
treeee21c963a85dbaeccf77383e9bb8b32d4981bfca /graphics
parenta483156879437e300fe679e9094b62c947c4c44a (diff)
downloadfreebsd-ports-gnome-402f473319dd6ff40a5d93416e6b0fb7cbdd76e3.tar.gz
freebsd-ports-gnome-402f473319dd6ff40a5d93416e6b0fb7cbdd76e3.tar.zst
freebsd-ports-gnome-402f473319dd6ff40a5d93416e6b0fb7cbdd76e3.zip
Support CXX/CXXFLAGS properly
PR: 44348 Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/multivideo/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/graphics/multivideo/Makefile b/graphics/multivideo/Makefile
index ac986ebbccb0..a846152300e5 100644
--- a/graphics/multivideo/Makefile
+++ b/graphics/multivideo/Makefile
@@ -14,12 +14,21 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= wx_gtk-2.2:${PORTSDIR}/x11-toolkits/wxgtk
+LIB_DEPENDS= wx_gtk-2.2.2:${PORTSDIR}/x11-toolkits/wxgtk
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-ALL_TARGET= # empty
+MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
+ALL_TARGET= default
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|g++|\$$\(CXX)|g ; \
+ s|-O2 -g -Wall -W|\$$\(CXXFLAGS\)|g ; \
+ s|[(]CC[)]|\(CXX\)|g ; \
+ s|gcc|\$$\(CXX\)|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/multivideo ${PREFIX}/bin