aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-10-06 04:17:59 +0800
committertijl <tijl@FreeBSD.org>2014-10-06 04:17:59 +0800
commit4da2650e76cadc2fc35c992097722a5ed416b3f2 (patch)
tree8a240ec33cafee3b4f7f73dd297c6727201b2c14 /graphics
parent4cc19c8f0410410a521135941b2780e9f7e510cf (diff)
downloadfreebsd-ports-gnome-4da2650e76cadc2fc35c992097722a5ed416b3f2.tar.gz
freebsd-ports-gnome-4da2650e76cadc2fc35c992097722a5ed416b3f2.tar.zst
freebsd-ports-gnome-4da2650e76cadc2fc35c992097722a5ed416b3f2.zip
graphics/gts:
- Convert to USES=libtool and bump dependent ports - Convert to USES=pathfix - Add INSTALL_TARGET=install-strip
Diffstat (limited to 'graphics')
-rw-r--r--graphics/graphviz/Makefile2
-rw-r--r--graphics/gts/Makefile15
-rw-r--r--graphics/gts/files/patch-gts.pc.in10
-rw-r--r--graphics/gts/files/patch-ltmain.sh15
-rw-r--r--graphics/gts/pkg-plist3
-rw-r--r--graphics/pygts/Makefile2
6 files changed, 10 insertions, 37 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index a790cbad42b6..3960177ce207 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= graphviz
PORTVERSION= 2.38.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics tk
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index b08f049a3214..bc29f5ef4c9e 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gts
PORTVERSION= 0.7.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF
@@ -14,9 +14,10 @@ LICENSE= LGPL20
CONFLICTS= pcb-[0-9]*
-USES= pkgconfig
-USE_GNOME= glib20
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool pathfix pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
OPTIONS_DEFINE= NETPBM
@@ -26,18 +27,14 @@ NETPBM_DESC= Build with libnetpbm support
NETPBM_LIB_DEPENDS= libnetpbm.so:${PORTSDIR}/graphics/netpbm
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
-post-extract:
+post-patch:
.if ! ${PORT_OPTIONS:MNETPBM}
@${REINPLACE_CMD} -e 's|netpbm="true"|netpbm="false"|' \
${WRKSRC}/configure
.endif
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-release \$$(LT_RELEASE)||g ; s|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|'
-
.include <bsd.port.mk>
diff --git a/graphics/gts/files/patch-gts.pc.in b/graphics/gts/files/patch-gts.pc.in
deleted file mode 100644
index 5139463482b0..000000000000
--- a/graphics/gts/files/patch-gts.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./gts.pc.in.orig 2005-01-19 04:48:19.000000000 +0000
-+++ ./gts.pc.in 2013-12-29 08:54:18.000000000 +0000
-@@ -6,6 +6,6 @@
- Name: GTS
- Description: GNU Triangulated Surface Library
- Version: @VERSION@
- Requires: glib-2.0,gthread-2.0,gmodule-2.0
--Libs: -L${libdir} @LIBS@ -lgts
-+Libs: -L${libdir} @LIBS@ -lgts -lm
- Cflags: -I${includedir}
diff --git a/graphics/gts/files/patch-ltmain.sh b/graphics/gts/files/patch-ltmain.sh
deleted file mode 100644
index 27961553cad4..000000000000
--- a/graphics/gts/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Wed Jun 9 16:34:57 2004
-+++ ltmain.sh Wed Jun 9 16:35:11 2004
-@@ -5457,10 +5457,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/gts/pkg-plist b/graphics/gts/pkg-plist
index 2898345f9716..6675a2c6fa4c 100644
--- a/graphics/gts/pkg-plist
+++ b/graphics/gts/pkg-plist
@@ -11,8 +11,9 @@ bin/stl2gts
bin/transform
include/gts.h
include/gtsconfig.h
+lib/libgts-0.7.so.5
+lib/libgts-0.7.so.5.0.1
lib/libgts.a
lib/libgts.so
-lib/libgts.so.5
libdata/pkgconfig/gts.pc
share/aclocal/gts.m4
diff --git a/graphics/pygts/Makefile b/graphics/pygts/Makefile
index 1e0cc349ceba..baa2858087d3 100644
--- a/graphics/pygts/Makefile
+++ b/graphics/pygts/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pygts
PORTVERSION= 0.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics python
MASTER_SITES= SF