aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-06-11 04:51:46 +0800
committerthierry <thierry@FreeBSD.org>2004-06-11 04:51:46 +0800
commit4eedc1cb29de18801240d3551754be2521c7b353 (patch)
tree3dcb627dd85b63617160d4219e9345a518e0ff82 /graphics
parent542326bb6389ef245ebcf60ac8818342db594a1b (diff)
downloadfreebsd-ports-gnome-4eedc1cb29de18801240d3551754be2521c7b353.tar.gz
freebsd-ports-gnome-4eedc1cb29de18801240d3551754be2521c7b353.tar.zst
freebsd-ports-gnome-4eedc1cb29de18801240d3551754be2521c7b353.zip
Add SciPlot 1.36, a full-featured Xt widget to display 2D data in a
graph.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/SciPlot/Makefile48
-rw-r--r--graphics/SciPlot/distinfo2
-rw-r--r--graphics/SciPlot/files/patch-Imakefile61
-rw-r--r--graphics/SciPlot/pkg-descr13
-rw-r--r--graphics/SciPlot/pkg-plist11
6 files changed, 136 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e13804bb6a86..9aae78b67d78 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -12,6 +12,7 @@
SUBDIR += IPA
SUBDIR += ImageMagick
SUBDIR += OpenEXR
+ SUBDIR += SciPlot
SUBDIR += aalib
SUBDIR += acidwarp
SUBDIR += ale
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
new file mode 100644
index 000000000000..3031a81ba4ec
--- /dev/null
+++ b/graphics/SciPlot/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: SciPlot
+# Date created: Mon June 8 2004
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= SciPlot
+PORTVERSION= 1.36
+CATEGORIES= graphics math
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= widgets
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A full-featured Xt widget to display 2D data in a graph
+
+USE_MOTIF= yes
+USE_IMAKE= yes
+MAKE_ENV= EXTRA_DEFINES="-fPIC" LIBNAME=${LIBNAME}
+INSTALLS_SHLIB= yes
+
+INCLUDES= SciPlot.h SciPlotP.h SciPlotUtil.h
+LIBNAME= lib${PORTNAME:L} # Remove :L for libSciPlot
+PLIST_SUB= LIBNAME=${LIBNAME}
+
+PORTDOCS= README SciPlot.html SciPlotDemo.html SciPlotProg.html
+EXDATA= data.txt
+EXBINS= realtime sciplot
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${INCLUDES:S|^|${WRKSRC}/|} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${LIBNAME}.a ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/${LIBNAME}.so.0 ${PREFIX}/lib
+ (cd ${PREFIX}/lib; ${LN} -sf ${LIBNAME}.so.0 ${LIBNAME}.so)
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXDATA:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${EXBINS:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/SciPlot/distinfo b/graphics/SciPlot/distinfo
new file mode 100644
index 000000000000..2643ca5c06c1
--- /dev/null
+++ b/graphics/SciPlot/distinfo
@@ -0,0 +1,2 @@
+MD5 (SciPlot-1.36.tar.gz) = 16eba60d505cf854e2f4b9837566d141
+SIZE (SciPlot-1.36.tar.gz) = 82673
diff --git a/graphics/SciPlot/files/patch-Imakefile b/graphics/SciPlot/files/patch-Imakefile
new file mode 100644
index 000000000000..438d9b70803c
--- /dev/null
+++ b/graphics/SciPlot/files/patch-Imakefile
@@ -0,0 +1,61 @@
+--- Imakefile.orig Thu Sep 5 04:32:58 1996
++++ Imakefile Wed Jun 9 17:27:01 2004
+@@ -1,3 +1,4 @@
++# $FreeBSD$
+ XCOMM Imakefile for widget demo programs
+
+ #ifdef LinuxArchitecture
+@@ -17,10 +18,10 @@
+ CC = cc -std1
+ #endif
+
+-MOTIF = $(LESSTIF) -lXm
++# MOTIF = $(LESSTIF) -lXm
+
+ MOTIFDEPS = $(DEPXMLIB) $(DEPXMULIB) $(DEPXTOOLLIB) $(DEPXLIB)
+-MOTIFLIBS = $(MOTIF) $(XMULIB) $(XTOOLLIB) $(XLIB)
++# MOTIFLIBS = $(MOTIF) $(XMULIB) $(XTOOLLIB) $(XLIB)
+ SYS_LIBRARIES = -lm
+ CDEBUGFLAGS =
+
+@@ -28,6 +29,9 @@
+ PROGRAMS = sciplot realtime
+ TARFILE = sciplot
+
++SONUM = 0
++SONAME = $(LIBNAME).so
++
+ SRCS = SciPlot.c SciPlotUtil.c xyplot.c realtime.c
+ HDRS = SciPlot.h SciPlotP.h SciPlotUtil.h
+ OBJS = $(SRCS:.c=.o)
+@@ -54,10 +58,10 @@
+ $(HDOC) $*.hdoc > $*.html
+
+
+-AllTarget(sciplot realtime)
++AllTarget(sciplot realtime libs)
+
+-NormalProgramTarget(sciplot,$(PLOTOBJS),$(MOTIFDEPS),$(MOTIFLIBS),$(SYS_LIBRARIES))
+-NormalProgramTarget(realtime,$(RTOBJS),$(MOTIFDEPS),$(MOTIFLIBS),$(SYS_LIBRARIES))
++NormalProgramTarget(sciplot,$(PLOTOBJS),$(MOTIFDEPS),$(MOTIFLIB),$(SYS_LIBRARIES))
++NormalProgramTarget(realtime,$(RTOBJS),$(MOTIFDEPS),$(MOTIFLIB),$(SYS_LIBRARIES))
+
+ doc: $(HOBJS) $(HDOC)
+ @echo "Updated html."
+@@ -79,9 +83,16 @@
+ tar cfv $(TARFILE).tar $(TARFILES)
+ compress $(TARFILE).tar
+
++libs: $(PLOTOBJS)
++ $(AR) $(LIBNAME).a $(WIDGET).o $(WIDGET)Util.o
++ $(RANLIB) $(LIBNAME).a
++ $(CC) $(SHLIBLDFLAGS) -o $(SONAME).$(SONUM) $(WIDGET).o $(WIDGET)Util.o \
++ $(LDFLAGS) $(MOTIFLIB) $(LDLIBS)
++
+ # Dependencies:
+
+ SciPlot.o: SciPlot.c SciPlotP.h SciPlot.h
+ SciPlotUtil.o: SciPlotUtil.c SciPlotUtil.h
+ xyplot.o: xyplot.c SciPlot.h SciPlotUtil.h
+ realtime.o: realtime.c SciPlot.h SciPlotUtil.h
++libsciplot.a: SciPlot.h SciPlotP.h SciPlotUtil.h SciPlot.c SciPlotUtil.c
diff --git a/graphics/SciPlot/pkg-descr b/graphics/SciPlot/pkg-descr
new file mode 100644
index 000000000000..d1d97248735d
--- /dev/null
+++ b/graphics/SciPlot/pkg-descr
@@ -0,0 +1,13 @@
+The SciPlot Widget is a widget capable of plotting cartesian or polar graphs,
+including logarithmic axes in cartesian plots. The widget is subclassed
+directly from the Core widget class, which means that it does not depend upon
+any other widget set. It may be freely used with Athena, Motif, or the Open
+Look/Xview widget sets.
+
+Features provided in the widget include automatic scaling, legend drawing, axis
+labeling, PostScript output, multiple plotted lines, color support, user font
+specification, dashed lines, symbols drawn at points, logarithmic scales on one
+or both axes in cartesian plots, and degrees or radians as angles in polar
+plots.
+
+WWW: http://www.questconsult.com/~jrm/SciPlot.html
diff --git a/graphics/SciPlot/pkg-plist b/graphics/SciPlot/pkg-plist
new file mode 100644
index 000000000000..d234528246d0
--- /dev/null
+++ b/graphics/SciPlot/pkg-plist
@@ -0,0 +1,11 @@
+include/SciPlot/SciPlot.h
+include/SciPlot/SciPlotP.h
+include/SciPlot/SciPlotUtil.h
+lib/%%LIBNAME%%.a
+lib/%%LIBNAME%%.so
+lib/%%LIBNAME%%.so.0
+%%PORTDOCS%%%%EXAMPLESDIR%%/data.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/realtime
+%%PORTDOCS%%%%EXAMPLESDIR%%/sciplot
+@dirrm include/SciPlot
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%