aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
commit4f3e737e3339df65a7737d86948a5c8dacedae60 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /graphics
parent38d22f91997e71dd03618ec2d16c51e19e000cd9 (diff)
downloadfreebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.gz
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.zst
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evince/Makefile71
1 files changed, 34 insertions, 37 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 7747de598367..aa1bf25f0794 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: evince
-# Date created: 09 January 2005
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/graphics/evince/Makefile,v 1.147 2010/09/28 07:27:12 kwm Exp $
-#
+# $MCom: ports/graphics/evince/Makefile,v 1.159 2012/09/01 23:02:10 mezz Exp $
PORTNAME= evince
PORTVERSION= 2.32.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,11 +13,14 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 multi-format document viewer
BUILD_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
-LIB_DEPENDS= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib \
- spectre.1:${PORTSDIR}/print/libspectre
+LIB_DEPENDS= poppler-glib:${PORTSDIR}/graphics/poppler-glib \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ spectre:${PORTSDIR}/print/libspectre
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme \
yelp:${PORTSDIR}/x11/yelp
+CONFLICTS= evince-3.[0-9]*
+
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
@@ -29,7 +28,8 @@ INSTALLS_ICONS= yes
USE_GETTEXT= yes
USE_GMAKE= yes
INSTALLS_OMF= yes
-USE_GNOME= gnomehack intlhack gnomeprefix desktopfileutils \
+USES= pathfix
+USE_GNOME= intlhack gnomeprefix desktopfileutils \
gnomedocutils ltasneededhack gconf2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -43,46 +43,47 @@ PLIST_SUB+= VERSION=2.32
MAN1= evince.1
-OPTIONS= DVI "Enable DVI viewer support" off \
- T1LIB "Enable T1LIB for TYPE1 fonts to DVI (Enables DVI)" off \
- NAUTILUS "Enable Nautilus plugin" on \
- KEYRING "Enable Gnome-Keyring without Nautilus" on \
- DBUS "Enable D-BUS support" on \
- COMICS "Enable comic book archives support" on \
- IMPRESS "Enable Impress presentations support" off \
- DJVU "Enable DJVU support" off
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DVI T1LIB NAUTILUS KEYRING COMICS IMPRESS DJVU
+OPTIONS_DEFAULT=NAUTILUS KEYRING COMICS
+DVI_DESC= DVI viewer support
+T1LIB_DESC= T1LIB for TYPE1 fonts to DVI (Enables DVI)
+NAUTILUS_DESC= Nautilus plugin
+KEYRING_DESC= Gnome-Keyring without Nautilus
+COMICS_DESC= Comic book archives support
+IMPRESS_DESC= Impress presentations support
+DJVU_DESC= DJVU support
-.if defined(PACKAGE_BUILDING) || exists(${LOCALBASE}/lib/libdbus-glib-1.so)
-WITH_DBUS= yes
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_DVI) || defined(WITH_T1LIB) || exists(${LOCALBASE}/lib/libkpathsea.a)
+.if ${PORT_OPTIONS:MDVI} || ${PORT_OPTIONS:MT1LIB}
BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX-base
RUN_DEPENDS+= tex:${PORTSDIR}/print/teTeX-base
CONFIGURE_ARGS+= --enable-dvi
GCONF_SCHEMAS+= evince-thumbnailer-dvi.schemas
PLIST_SUB+= DVI=""
-. if defined(WITH_T1LIB)
-LIB_DEPENDS+= t1.5:${PORTSDIR}/devel/t1lib
+. if defined(WITH_T1LIB)
+LIB_DEPENDS+= t1:${PORTSDIR}/devel/t1lib
CONFIGURE_ARGS+= --enable-t1lib
+. else
+CONFIGURE_ARGS+= --disable-t1lib
. endif
+
.else
+CONFIGURE_ARGS+= --disable-dvi
PLIST_SUB+= DVI="@comment "
.endif
-.if !defined(WITHOUT_NAUTILUS)
+.if ${PORT_OPTIONS:MNAUTILUS}
USE_GNOME+= nautilus2
CONFIGURE_ARGS+= --enable-nautilus
PLIST_SUB+= NAUTILUS=""
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
RUN_DEPENDS+= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
-.if !defined(WITHOUT_KEYRING)
-LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
+.if ${PORT_OPTIONS:MKEYRING}
+LIB_DEPENDS+= gnome-keyring:${PORTSDIR}/security/libgnome-keyring
.else
CONFIGURE_ARGS+= --without-keyring
.endif
@@ -90,7 +91,7 @@ CONFIGURE_ARGS+= --disable-nautilus
PLIST_SUB+= NAUTILUS="@comment "
.endif
-.if defined(WITH_IMPRESS)
+.if ${PORT_OPTIONS:MIMPRESS}
CONFIGURE_ARGS+= --enable-impress
PLIST_SUB+= IMPRESS=""
.else
@@ -98,7 +99,7 @@ CONFIGURE_ARGS+= --disable-impress
PLIST_SUB+= IMPRESS="@comment "
.endif
-.if defined(WITH_DJVU)
+.if ${PORT_OPTIONS:MDJVU}
LIB_DEPENDS+= djvulibre:${PORTSDIR}/graphics/djvulibre
CONFIGURE_ARGS+= --enable-djvu
GCONF_SCHEMAS+= evince-thumbnailer-djvu.schemas
@@ -108,11 +109,7 @@ CONFIGURE_ARGS+= --disable-djvu
PLIST_SUB+= DJVU="@comment "
.endif
-.if !defined(WITHOUT_DBUS)
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-.endif
-
-.if !defined(WITHOUT_COMICS)
+.if ${PORT_OPTIONS:MCOMICS}
RUN_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
CONFIGURE_ARGS+= --enable-comics
GCONF_SCHEMAS+= evince-thumbnailer-comics.schemas
@@ -133,4 +130,4 @@ post-patch:
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>