aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-03-19 18:45:37 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-03-19 18:45:37 +0800
commit549ba99b47568d081f56483cc7eca16341187862 (patch)
tree04b8106e42665c7fdaaf45e3cd7d572476fc5255 /graphics
parentf226e6b13f2ca285a19e8bd04d6b6d684165f6d3 (diff)
downloadfreebsd-ports-gnome-549ba99b47568d081f56483cc7eca16341187862.tar.gz
freebsd-ports-gnome-549ba99b47568d081f56483cc7eca16341187862.tar.zst
freebsd-ports-gnome-549ba99b47568d081f56483cc7eca16341187862.zip
- Unbreak port by using CHEESESHOP master site instead of GOOGLE_CODE as this
port is still needed by ports (eg. mail/cleanup-maildir) - While here add LICENSE - The distfile checksums differ due to some minor changes [1], therefore also bump PORTREVISION [1] --- distfile changes begin here --- diff -Nur google/python-graph-core-1.8.2/PKG-INFO cheeseshop/python-graph-core-1.8.2/PKG-INFO --- google/python-graph-core-1.8.2/PKG-INFO 2012-07-14 23:12:33.000000000 +0200 +++ cheeseshop/python-graph-core-1.8.2/PKG-INFO 2015-03-26 22:07:53.000000000 +0100 @@ -1,4 +1,4 @@ -Metadata-Version: 1.0 +Metadata-Version: 1.1 Name: python-graph-core Version: 1.8.2 Summary: A library for working with graphs in Python diff -Nur google/python-graph-core-1.8.2/pygraph/algorithms/minmax.py cheeseshop/python-graph-core-1.8.2/pygraph/algorithms/minmax.py --- google/python-graph-core-1.8.2/pygraph/algorithms/minmax.py 2012-02-19 20:36:08.000000000 +0100 +++ cheeseshop/python-graph-core-1.8.2/pygraph/algorithms/minmax.py 2014-03-11 00:04:22.000000000 +0100 @@ -132,6 +132,13 @@ # Shortest Path +def path(st, target): + if (target is None): + return [] + else: + return [target] + path(st, st[target]) + + def shortest_path(graph, source): """ Return the shortest path distance between source and all other nodes using Dijkstra's diff -Nur google/python-graph-core-1.8.2/python_graph_core.egg-info/PKG-INFO cheeseshop/python-graph-core-1.8.2/python_graph_core.egg-info/PKG-INFO --- google/python-graph-core-1.8.2/python_graph_core.egg-info/PKG-INFO 2012-07-14 23:12:33.000000000 +0200 +++ cheeseshop/python-graph-core-1.8.2/python_graph_core.egg-info/PKG-INFO 2015-03-26 22:07:51.000000000 +0100 @@ -1,4 +1,4 @@ -Metadata-Version: 1.0 +Metadata-Version: 1.1 Name: python-graph-core Version: 1.8.2 Summary: A library for working with graphs in Python diff -Nur google/python-graph-core-1.8.2/python_graph_core.egg-info/top_level.txt cheeseshop/python-graph-core-1.8.2/python_graph_core.egg-info/top_level.txt --- google/python-graph-core-1.8.2/python_graph_core.egg-info/top_level.txt 2012-07-14 23:12:33.000000000 +0200 +++ cheeseshop/python-graph-core-1.8.2/python_graph_core.egg-info/top_level.txt 2015-03-26 22:07:51.000000000 +0100 @@ -1,5 +1,5 @@ -pygraph/classes -pygraph/readwrite pygraph -pygraph/mixins pygraph/algorithms +pygraph/classes +pygraph/mixins +pygraph/readwrite --- distfile changes end here ---
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-graph-core/Makefile9
-rw-r--r--graphics/py-graph-core/distinfo5
2 files changed, 6 insertions, 8 deletions
diff --git a/graphics/py-graph-core/Makefile b/graphics/py-graph-core/Makefile
index 010574ee5388..7725228d4ac1 100644
--- a/graphics/py-graph-core/Makefile
+++ b/graphics/py-graph-core/Makefile
@@ -3,20 +3,17 @@
PORTNAME= graph-core
PORTVERSION= 1.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= demon@FreeBSD.org
COMMENT= Library for working with graphs in Python, core module
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
+LICENSE= MIT
-PROJECTHOST= python-graph
USES= python
USE_PYTHON= distutils autoplist
diff --git a/graphics/py-graph-core/distinfo b/graphics/py-graph-core/distinfo
index b71bdca274ab..93321eb190dc 100644
--- a/graphics/py-graph-core/distinfo
+++ b/graphics/py-graph-core/distinfo
@@ -1,2 +1,3 @@
-SHA256 (python-graph-core-1.8.2.tar.gz) = 90834ed30d2c8d1ade30550d82dae2a3bf274270d5bef51d26e7f35b6262ae32
-SIZE (python-graph-core-1.8.2.tar.gz) = 27361
+TIMESTAMP = 1489918992
+SHA256 (python-graph-core-1.8.2.tar.gz) = 503fa45f42b3bfa8b62db1357afaec52fe0e9104e27e905e24784ef62347fc21
+SIZE (python-graph-core-1.8.2.tar.gz) = 27414