aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2012-11-03 21:18:37 +0800
committerbsam <bsam@FreeBSD.org>2012-11-03 21:18:37 +0800
commit6352f02be3ce5cd0d37a96bb71ba7d3b5adebd33 (patch)
tree09fe6dbd2840da62bb77cb4bd34e2baaa5466d0c /graphics
parentafcb30b37bccb49bc6fbf8b3e6e4614761cf4b95 (diff)
downloadfreebsd-ports-gnome-6352f02be3ce5cd0d37a96bb71ba7d3b5adebd33.tar.gz
freebsd-ports-gnome-6352f02be3ce5cd0d37a96bb71ba7d3b5adebd33.tar.zst
freebsd-ports-gnome-6352f02be3ce5cd0d37a96bb71ba7d3b5adebd33.zip
. update to version 0.9.2;
. USE_GNOME=pkgconfig -> USE_PKGCONFIG=build; . make use of desktopfileutils for port and package; . use two line style headers. Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/yagf/Makefile15
-rw-r--r--graphics/yagf/distinfo4
-rw-r--r--graphics/yagf/files/patch-CMakeLists.txt15
-rw-r--r--graphics/yagf/files/patch-src-FileChannel.cpp11
-rw-r--r--graphics/yagf/pkg-plist5
5 files changed, 26 insertions, 24 deletions
diff --git a/graphics/yagf/Makefile b/graphics/yagf/Makefile
index 214798f6a458..f041f9dbbfed 100644
--- a/graphics/yagf/Makefile
+++ b/graphics/yagf/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: graphics/yagf
-# Date created: 2009-09-11
-# Whom: bsam
-#
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= yagf
-PORTVERSION= 0.8.1
-PORTREVISION= 4
+PORTVERSION= 0.9.2
CATEGORIES= graphics
MASTER_SITES= http://symmetrica.net/cuneiform-linux/
@@ -20,12 +15,16 @@ ONLY_FOR_ARCHS= i386 amd64
USE_CMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig
INSTALLS_ICONS= yes
+USE_PKGCONFIG= build
+USE_GNOME= desktopfileutils
USE_QT4= corelib gui imageformats linguist_build \
moc_build qmake_build rcc_build uic_build
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
+post-install:
+ -update-desktop-database
+
.include <bsd.port.mk>
diff --git a/graphics/yagf/distinfo b/graphics/yagf/distinfo
index 343e111bd5ff..e299cadbc421 100644
--- a/graphics/yagf/distinfo
+++ b/graphics/yagf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yagf-0.8.1.tar.gz) = f520629cf36e346bfa032a12fd6a84b14ab7d48d5e86d1fd3340d94cbb7f4f03
-SIZE (yagf-0.8.1.tar.gz) = 189938
+SHA256 (yagf-0.9.2.tar.gz) = 1099760462c029aa9919ef96809a1b0252d8d735d9d0807ce790f9d3e1e271b8
+SIZE (yagf-0.9.2.tar.gz) = 258305
diff --git a/graphics/yagf/files/patch-CMakeLists.txt b/graphics/yagf/files/patch-CMakeLists.txt
index 65d8f2893de1..aa8730ce56b6 100644
--- a/graphics/yagf/files/patch-CMakeLists.txt
+++ b/graphics/yagf/files/patch-CMakeLists.txt
@@ -1,6 +1,15 @@
---- CMakeLists.txt.orig 2009-08-16 20:54:20.000000000 +0400
-+++ CMakeLists.txt 2009-09-14 13:09:48.000000000 +0400
-@@ -25,12 +25,12 @@
+--- CMakeLists.txt.orig 2012-09-04 15:00:25.000000000 +0400
++++ CMakeLists.txt 2012-11-03 02:04:20.000000000 +0400
+@@ -34,7 +34,7 @@ qt4_add_resources(yagf_RCC_SRCS ${yagf_R
+ include_directories( ${CMAKE_BINARY_DIR} ${PROJECT_SOURCE_DIR}/src)
+ add_executable(yagf ${SOURCES} ${UI_HEADERS} ${MOC_SRCS} ${yagf_RCC_SRCS} ${QM_FILES})
+ add_library(xspreload SHARED ${INT_SOURCES})
+-target_link_libraries(xspreload dl)
++target_link_libraries(xspreload)
+ target_link_libraries(yagf ${QT_LIBRARIES} ${ASPELL_LIBRARIES} ${TIFF_LIBRARIES})
+ add_custom_target(translations DEPENDS ${QM_FILES})
+ qt4_add_translation(${CMAKE_BINARY_DIR}/yagf_ru.qm ${PROJECT_SOURCE_DIR}/src/mainform.cpp ${PROJECT_SOURCE_DIR}/src/popplerdialog.cpp ${MOC_SRCS} ${UI_HEADERS} ${PROJECT_SOURCE_DIR}/src/translations/yagf_ru.ts)
+@@ -45,12 +45,12 @@ qt4_add_translation(${CMAKE_BINARY_DIR}/
#QT4_CREATE_TRANSLATION(yagf_ru.qm src/mainform.cpp ${MOC_SRCS} ${UI_HEADERS} src/yagf_ru.ts)
#set(CMAKE_INSTALL_PREFIX /usr/)
if (NOT DEFINED ${CMAKE_INSTALL_PREFIX})
diff --git a/graphics/yagf/files/patch-src-FileChannel.cpp b/graphics/yagf/files/patch-src-FileChannel.cpp
deleted file mode 100644
index ace4b0a13f9c..000000000000
--- a/graphics/yagf/files/patch-src-FileChannel.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/FileChannel.cpp.orig 2009-09-12 13:08:28.000000000 +0400
-+++ src/FileChannel.cpp 2009-09-12 13:08:41.000000000 +0400
-@@ -248,7 +248,7 @@
-
- QString FileChannel::errorString()
- {
-- strcpy(lastErrorString, strerror_r(errno, lastErrorString, 0));
-+ strcpy(lastErrorString, strerror(errno));
- return QString(trUtf8(lastErrorString));
- }
-
diff --git a/graphics/yagf/pkg-plist b/graphics/yagf/pkg-plist
index 2d359548d702..bf4aa89a05db 100644
--- a/graphics/yagf/pkg-plist
+++ b/graphics/yagf/pkg-plist
@@ -3,8 +3,11 @@ lib/yagf/libxspreload.so
share/applications/YAGF.desktop
share/icons/hicolor/96x96/apps/yagf.png
share/pixmaps/yagf.png
+share/yagf/translations/yagf_de.qm
share/yagf/translations/yagf_lt.qm
+share/yagf/translations/yagf_pl.qm
share/yagf/translations/yagf_ru.qm
+share/yagf/translations/yagf_uk.qm
@comment those are yagf directories
@dirrm lib/yagf
@dirrm share/yagf/translations
@@ -15,3 +18,5 @@ share/yagf/translations/yagf_ru.qm
@dirrmtry share/icons/hicolor/96x96
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
+@exec %%LOCALBASE%%/bin/update-desktop-database || :
+@unexec %%LOCALBASE%%/bin/update-desktop-database || :