aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2007-03-30 04:57:15 +0800
committershaun <shaun@FreeBSD.org>2007-03-30 04:57:15 +0800
commit637123f469b8d69beb7015a7909b068554067f85 (patch)
tree916f3375c23428283bc35027ca76fdbe5ad06efe /graphics
parent038751df6189a493b9bdff36a572e00e08f3ce36 (diff)
downloadfreebsd-ports-gnome-637123f469b8d69beb7015a7909b068554067f85.tar.gz
freebsd-ports-gnome-637123f469b8d69beb7015a7909b068554067f85.tar.zst
freebsd-ports-gnome-637123f469b8d69beb7015a7909b068554067f85.zip
Fix build with graphviz support in some cases where it fails.
PR: ports/111018 Submitted by: Scot Hetzel <swhetzel@gmail.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 37679622a2dd..726da4034156 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -181,8 +181,9 @@ PLIST_SUB+= JPEG2000="@comment "
# GraphViz dot graphs
.if defined(WITH_IMAGEMAGICK_DOT)
-BUILD_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
-RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
+LIB_DEPENDS+= gvc.3:${PORTSDIR}/graphics/graphviz
+CFLAGS+= -I${LOCALBASE}/include/graphviz
+LDFLAGS+= -L${LOCALBASE}/lib/graphviz
.else
CONFIGURE_ARGS+= --without-dot --without-gvc
.endif