aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2007-04-24 01:11:49 +0800
committeracm <acm@FreeBSD.org>2007-04-24 01:11:49 +0800
commit6dc8c12f881305ba6ee027dc13c1506f0a1e7c69 (patch)
treee814db47bc3fc1c8d7843ee121471268c5322064 /graphics
parent84b942d73ff3f245cded9a260fa80d2526749618 (diff)
downloadfreebsd-ports-gnome-6dc8c12f881305ba6ee027dc13c1506f0a1e7c69.tar.gz
freebsd-ports-gnome-6dc8c12f881305ba6ee027dc13c1506f0a1e7c69.tar.zst
freebsd-ports-gnome-6dc8c12f881305ba6ee027dc13c1506f0a1e7c69.zip
- Add FFMPEG_DEVEL option
PR: 111919 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet__at sunpoet.net> Reviewed by: me
Diffstat (limited to 'graphics')
-rw-r--r--graphics/php4-ffmpeg/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/graphics/php4-ffmpeg/Makefile b/graphics/php4-ffmpeg/Makefile
index edb0ffa0d38e..83a40d02e1a1 100644
--- a/graphics/php4-ffmpeg/Makefile
+++ b/graphics/php4-ffmpeg/Makefile
@@ -18,8 +18,7 @@ EXTRACT_SUFX= .tbz2
MAINTAINER= acm@FreeBSD.org
COMMENT= The ffmpeg shared extension for php
-LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
USE_BZIP2= yes
USE_PHP= yes
@@ -29,4 +28,14 @@ IGNORE_WITH_PHP?=5
DEFAULT_PHP_VER?=4
CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
-.include <bsd.port.mk>
+OPTIONS= FFMPEG_DEVEL "Use ffmpeg development version" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_FFMPEG_DEVEL)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.else
+LIB_DEPENDS+= avutil.1:${PORTSDIR}/multimedia/ffmpeg-devel
+.endif
+
+.include <bsd.port.post.mk>