aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 21:44:00 +0800
committermat <mat@FreeBSD.org>2013-08-03 21:44:00 +0800
commit75dd7415d6d89e4f6c03a98e4dd8589865c9cb43 (patch)
tree5fff787fcf509ed53762690c395516c337412423 /graphics
parent3e657489e209d0aec5331fd70f19c96df0146a59 (diff)
downloadfreebsd-ports-gnome-75dd7415d6d89e4f6c03a98e4dd8589865c9cb43.tar.gz
freebsd-ports-gnome-75dd7415d6d89e4f6c03a98e4dd8589865c9cb43.tar.zst
freebsd-ports-gnome-75dd7415d6d89e4f6c03a98e4dd8589865c9cb43.zip
- Convert to new perl framework
- Remove MAKE_JOBS_SAFE=yes, it's the default.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dynamechs/Makefile3
-rw-r--r--graphics/giram/Makefile4
-rw-r--r--graphics/gtkgraph/Makefile4
-rw-r--r--graphics/icoutils/Makefile4
-rw-r--r--graphics/ida/Makefile5
-rw-r--r--graphics/openrm/Makefile4
-rw-r--r--graphics/pvmpov/Makefile3
-rw-r--r--graphics/sam2p/Makefile4
-rw-r--r--graphics/xmandel/Makefile4
9 files changed, 18 insertions, 17 deletions
diff --git a/graphics/dynamechs/Makefile b/graphics/dynamechs/Makefile
index 544676c5ece3..51db9d174f3a 100644
--- a/graphics/dynamechs/Makefile
+++ b/graphics/dynamechs/Makefile
@@ -17,10 +17,11 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Multibody Dynamic Simulation Library
+USES= perl5
USE_BZIP2= yes
USE_GL= glut
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
CXXFLAGS+= ${PTHREAD_CFLAGS}
MAKE_ENV= OPENGLINCDIR="${LOCALBASE}/include" \
OPENGLLIBDIR="${LOCALBASE}/lib"
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 5a4b07d1e6be..72e9052a01fc 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= 3ds-1.3:${PORTSDIR}/graphics/lib3ds
BUILD_DEPENDS= povray:${PORTSDIR}/graphics/povray-meta
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gettext
-USE_PERL5_BUILD=yes
+USES= gettext perl5
+USE_PERL5= build
USE_GNOME= gtk20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
index 48b046ac9892..f688e8ac1125 100644
--- a/graphics/gtkgraph/Makefile
+++ b/graphics/gtkgraph/Makefile
@@ -11,10 +11,10 @@ MASTER_SITE_SUBDIR= jedgar
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphing calculator using GTK+
-USES= gettext
+USES= gettext perl5
USE_GMAKE= yes
USE_GNOME= imlib
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index bda2922c1e13..5cb13c60aa34 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -15,13 +15,13 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= RESSCRIPTS
RESSCRIPTS_DESC= PERL resource scripts
+RESSCRIPTS_USES= perl5
USE_BZIP2= yes
USES= shebangfix
SHEBANG_FILES= extresso/*.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls
-MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -34,7 +34,7 @@ PLIST_FILES= bin/icotool \
.if ${PORT_OPTIONS:MRESSCRIPTS}
RUN_DEPENDS+= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-USE_PERL5_RUN= yes
+USE_PERL5= run
MAN1+= extresso.1 genresscript.1
PLIST_FILES+= bin/extresso \
bin/genresscript
diff --git a/graphics/ida/Makefile b/graphics/ida/Makefile
index 1c64e94c239e..cb017dcb9a2e 100644
--- a/graphics/ida/Makefile
+++ b/graphics/ida/Makefile
@@ -21,11 +21,10 @@ OPTIONS_DEFAULT= GIF PNG TIFF
PCD_DESC= Enable PhotoCD support
SANE_DESC= Enable SANE support
-USE_PERL5_BUILD=yes
-USES= iconv gmake motif
+USE_PERL5= build
+USES= iconv gmake motif perl5
MAKEFILE= GNUmakefile
MAKE_ARGS= JPEG_VER=80 verbose=yes
-MAKE_JOBS_SAFE= yes
LDFLAGS+= -liconv
diff --git a/graphics/openrm/Makefile b/graphics/openrm/Makefile
index c9dde4851d82..59eee4117573 100644
--- a/graphics/openrm/Makefile
+++ b/graphics/openrm/Makefile
@@ -18,11 +18,11 @@ OPTIONS_DEFINE= DOCS EXAMPLES
WRKSRC= ${WRKDIR}/rm${PORTVERSION:R:S/.//g}
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= doc/*.pl
USE_GL= glu
USE_XORG= xmu
-USE_PERL5_BUILD=yes
+USE_PERL5= build
ALL_TARGET= freebsd docs
MAKE_ARGS= AR="${AR}" \
CC="${CC}" \
diff --git a/graphics/pvmpov/Makefile b/graphics/pvmpov/Makefile
index e1a4289ea6af..b2ebcb08e986 100644
--- a/graphics/pvmpov/Makefile
+++ b/graphics/pvmpov/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= povray31:${PORTSDIR}/graphics/povray31 \
pvmd:${PORTSDIR}/net/pvm
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
USE_XORG= x11
WRKSRC= ${WRKDIR}/pvmpov3_1g_2
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
index 9cc14099b12c..2330842e055a 100644
--- a/graphics/sam2p/Makefile
+++ b/graphics/sam2p/Makefile
@@ -17,14 +17,14 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
cjpeg:${PORTSDIR}/graphics/jpeg \
tif22pnm:${PORTSDIR}/graphics/tif22pnm
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
USE_GHOSTSCRIPT_RUN= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_pts_bash="${SH}"
MAKE_ARGS= CXXX="${CXX}" LDALL="${CXX}" CXXFLAGSB="${CXXFLAGS}"
ALL_TARGET= ${PORTNAME}
-MAKE_JOBS_SAFE= yes
PORTDOCS= README
PORTEXAMPLES= *
diff --git a/graphics/xmandel/Makefile b/graphics/xmandel/Makefile
index cec3816df6cd..aad5c3448dd3 100644
--- a/graphics/xmandel/Makefile
+++ b/graphics/xmandel/Makefile
@@ -17,9 +17,9 @@ COMMENT= Window based interface to Mandelbrot sets and Julia sets
EXTRACT_CMD= ${SH}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= # empty
-USES= imake
+USES= imake perl5
USE_XORG= ice sm x11 xaw xext xmu xt
-USE_PERL5_BUILD=yes
+USE_PERL5= build
NO_WRKSUBDIR= yes
MAN1= xmandel.1
PLIST_FILES= bin/xmandel