aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-10-08 02:48:29 +0800
committerdanfe <danfe@FreeBSD.org>2004-10-08 02:48:29 +0800
commit7d5bf847722e80ec4caef7cb31138bb286c8da15 (patch)
tree520281488792e1155702558946f7cfd1fa42fe5f /graphics
parent9a24e2a75b660ff32f63ff6947b365c3229a3c7d (diff)
downloadfreebsd-ports-gnome-7d5bf847722e80ec4caef7cb31138bb286c8da15.tar.gz
freebsd-ports-gnome-7d5bf847722e80ec4caef7cb31138bb286c8da15.tar.zst
freebsd-ports-gnome-7d5bf847722e80ec4caef7cb31138bb286c8da15.zip
Don't allow GCC to optimize away -lm test, and thus unbreak.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/geomview/Makefile8
-rw-r--r--graphics/geomview/files/patch-configure.in14
2 files changed, 13 insertions, 9 deletions
diff --git a/graphics/geomview/Makefile b/graphics/geomview/Makefile
index 12480164b7d2..e49244927392 100644
--- a/graphics/geomview/Makefile
+++ b/graphics/geomview/Makefile
@@ -42,12 +42,6 @@ MAKE_ENV= CPU=FreeBSD MAPLE_LIB=${MAPLE_LIB}
AC_FAKE_FILES= aclocal.m4 config.h.in stamp-h stamp-h.in
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-configure:
cd ${WRKSRC}; ${TOUCH} ${AC_FAKE_FILES}
${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${TOUCH}
@@ -74,4 +68,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/html/pix/*.gif ${DOCSDIR}/html/pix
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/geomview/files/patch-configure.in b/graphics/geomview/files/patch-configure.in
index 0ac72663638b..719c67c04525 100644
--- a/graphics/geomview/files/patch-configure.in
+++ b/graphics/geomview/files/patch-configure.in
@@ -11,7 +11,17 @@
*) MACHTYPE=$target_os
AC_DEFINE_UNQUOTED(MACHTYPE, "$MACHTYPE")
;;
-@@ -471,7 +471,8 @@
+@@ -459,7 +463,8 @@
+ # mbp Mon May 8 18:47:33 2000
+ AC_MSG_CHECKING([whether we need to link -lm to get math functions])
+ AC_TRY_LINK([ #include <math.h> ],
+- [ double s = sin(1.5); ],
++ [ double s = sin(1.5);
++ return ((int)s); ],
+ [ MATHLIB=""
+ AC_MSG_RESULT([no]) ],
+ [ MATHLIB=-lm
+@@ -471,7 +476,8 @@
AC_MSG_CHECKING([whether we need to link -lsocket to get socket()])
@@ -21,7 +31,7 @@
[ int s = socket(AF_UNIX, SOCK_STREAM, 0); ],
[ SOCKETLIBS=""
AC_MSG_RESULT([no]) ],
-@@ -491,10 +492,10 @@
+@@ -491,10 +497,10 @@
AC_CHECK_HEADERS(fpu_control.h i386/fpu_control.h netinet/in.h)