aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-12-05 06:28:56 +0800
committerstas <stas@FreeBSD.org>2009-12-05 06:28:56 +0800
commit7d862bb4e62ac9919bb2238cb61216d6d0998675 (patch)
tree8dfadd60dd292fe39a5ddaeeac61fad585818af3 /graphics
parent4b6f635e02135e75048e8e6ee0ecdac4499b1d1b (diff)
downloadfreebsd-ports-gnome-7d862bb4e62ac9919bb2238cb61216d6d0998675.tar.gz
freebsd-ports-gnome-7d862bb4e62ac9919bb2238cb61216d6d0998675.tar.zst
freebsd-ports-gnome-7d862bb4e62ac9919bb2238cb61216d6d0998675.zip
- Add CONTRAST option to support contrast operations (enabled by default). [1]
- Add HOTPIXEL option to support hot pixels filtering (enabled by default). - Add DST option that turns on using the local time in timestamps (off by default). - Bump port revision. PR: ports/141053 [1] Submitted by: "Pierre Guinoiseau" <geekounet@poildetroll.net> [1]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ufraw/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 0cd1c960dc57..c44d1c15d14f 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ufraw
PORTVERSION= 0.16
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -30,10 +30,13 @@ CPPFLAGS= -I"${LOCALBASE}/include"
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
PC_FALSE+= cinepaint
-OPTIONS= EXIV2 "EXIF support via exiv2 library" on \
+OPTIONS= CONTRAST "Enable contrast setting" on \
+ DST " Use local time for timestamps" off \
+ EXIV2 "EXIF support via exiv2 library" on \
+ FITS "Enable FITS output support" off \
GIMP "Install GIMP UFRaw plugin" on \
- LENSFUN "Build with LenFun library support" on \
- FITS "Enable FITS output support" off
+ HOTPIXEL "Enable hot pixels elimination" on \
+ LENSFUN "Build with LenFun library support" on
.include <bsd.port.pre.mk>
@@ -56,6 +59,15 @@ CONFIGURE_ARGS+= --with-lensfun
.if defined(WITH_FITS) || exists(${LOCALBASE}/lib/libcfitsio.so)
LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
.endif
+.if !defined(WITHOUT_CONTRAST)
+CONFIGURE_ARGS+= --enable-contrast
+.endif
+.if !defined(WITHOUT_HOTPIXEL)
+CONFIGURE_ARGS+= --enable-hotpixels
+.endif
+.if defined(WITH_DST)
+CONFIGURE_ARGS+= --enable-dst-correction
+.endif
MAN1= ufraw.1