aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2012-05-10 22:36:17 +0800
committerpav <pav@FreeBSD.org>2012-05-10 22:36:17 +0800
commit81e6ab5e41dc949144fc8af583597c5680fb6a93 (patch)
treedf92e37023be9f31f83c982376fba5bd839fb613 /graphics
parent6e3ec2de6ee6a0020a15be94c5714a36ab9759fa (diff)
downloadfreebsd-ports-gnome-81e6ab5e41dc949144fc8af583597c5680fb6a93.tar.gz
freebsd-ports-gnome-81e6ab5e41dc949144fc8af583597c5680fb6a93.tar.zst
freebsd-ports-gnome-81e6ab5e41dc949144fc8af583597c5680fb6a93.zip
- Add a dependency on yelp to enable help system
- Cosmetic change to glib patch PR: ports/167725, ports/167726 Submitted by: Ronald F.Guilmette <rfg@tristatelogic.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gthumb/Makefile9
-rw-r--r--graphics/gthumb/files/patch-glib-utils.c14
2 files changed, 18 insertions, 5 deletions
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index f96a4cc2062b..5679eeb0124a 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gthumb
PORTVERSION= 2.14.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -44,7 +44,8 @@ OPTIONS= EXIV2 "Exif support (image metadata)" On \
GSTREAMER "Video playback" On \
OPENRAW "Support for camera RAW files" On \
SOUP "Web services uploaders" On \
- BRASERO "Write galleries to CD/DVD (large dependency)" On
+ BRASERO "Write galleries to CD/DVD (large dependency)" On \
+ YELP "Viewer for built-in help system" On
.include <bsd.port.pre.mk>
@@ -100,4 +101,8 @@ CONFIGURE_ARGS+=--disable-libbrasero
PLIST_SUB+= BRASERO="@comment "
.endif
+.if defined(WITH_YELP)
+RUN_DEPENDS+= yelp:${PORTSDIR}/x11/yelp
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/gthumb/files/patch-glib-utils.c b/graphics/gthumb/files/patch-glib-utils.c
index f204e5e838b4..9f5ea644355d 100644
--- a/graphics/gthumb/files/patch-glib-utils.c
+++ b/graphics/gthumb/files/patch-glib-utils.c
@@ -1,11 +1,19 @@
--- gthumb/glib-utils.c.orig 2011-11-03 21:36:36.000000000 +0100
-+++ gthumb/glib-utils.c 2011-12-29 15:30:12.000000000 +0100
-@@ -552,7 +552,7 @@
++++ gthumb/glib-utils.c 2012-05-10 15:03:34.000000000 +0200
+@@ -552,7 +552,6 @@
{
int offset;
- offset = -timezone;
-+ offset = 0;
#if defined (HAVE_TM_GMTOFF)
offset = tm->tm_gmtoff;
#elif defined (HAVE_TIMEZONE)
+@@ -564,6 +563,8 @@
+ #endif
+ } else
+ offset = -timezone;
++#else
++ offset = 0;
+ #endif
+
+ return offset;