aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-06 18:34:16 +0800
committeraz <az@FreeBSD.org>2012-06-06 18:34:16 +0800
commit87e741950f4ede0fb4ac6117b9c142420a080773 (patch)
treef289a2780008afbd99ddc220562199f47ada70d1 /graphics
parent1c365e3e7d6c9a6ba7fe8f1f1c55096e25e06d6d (diff)
downloadfreebsd-ports-gnome-87e741950f4ede0fb4ac6117b9c142420a080773.tar.gz
freebsd-ports-gnome-87e741950f4ede0fb4ac6117b9c142420a080773.tar.zst
freebsd-ports-gnome-87e741950f4ede0fb4ac6117b9c142420a080773.zip
Trying to fix version detection of giflib (should fix pkg-plist).
Reported by: pavbot
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-Imager/files/patch-GIF_LIB_VERSION27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/p5-Imager/files/patch-GIF_LIB_VERSION b/graphics/p5-Imager/files/patch-GIF_LIB_VERSION
new file mode 100644
index 000000000000..fdeb861f4599
--- /dev/null
+++ b/graphics/p5-Imager/files/patch-GIF_LIB_VERSION
@@ -0,0 +1,27 @@
+--- GIF/Makefile.PL 2012-03-18 15:35:09.000000000 +0400
++++ GIF/Makefile.PL 2012-06-06 14:14:57.076093500 +0400
+@@ -109,6 +109,11 @@
+
+ sub _gif_test_code {
+ return <<'CODE';
++
++#ifndef GIF_LIB_VERSION
++#define GIF_LIB_VERSION " Version 4.2, "
++#endif
++
+ /* TODO: test DGifOpen() and processing with callbacks */
+ GifFileType *gf;
+ const char vers[] = GIF_LIB_VERSION;
+--- GIF/imgif.c 2011-11-25 14:31:00.000000000 +0400
++++ GIF/imgif.c 2012-06-06 14:15:13.033980092 +0400
+@@ -10,6 +10,10 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++#ifndef GIF_LIB_VERSION
++#define GIF_LIB_VERSION " Version 4.2, "
++#endif
++
+ /*
+ =head1 NAME
+