aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2012-11-06 12:52:08 +0800
committerdanfe <danfe@FreeBSD.org>2012-11-06 12:52:08 +0800
commit886abbfcb0906cd89c4ef565e4bd4459a51cd485 (patch)
treeec1343f86fee64f82d88fe11a3cb51260aab259d /graphics
parentcc5e6f7345338abe2437ad9000a69b103af661fa (diff)
downloadfreebsd-ports-gnome-886abbfcb0906cd89c4ef565e4bd4459a51cd485.tar.gz
freebsd-ports-gnome-886abbfcb0906cd89c4ef565e4bd4459a51cd485.tar.zst
freebsd-ports-gnome-886abbfcb0906cd89c4ef565e4bd4459a51cd485.zip
graphics/gexiv2:
- Update to version 0.4.1 - Drop shlib versions in LIB_DEPENDS - Define LICENSE (GPLv2) - Cleanup Makefile and port description graphics/shotwell (gexiv2 consumer): - Bump port revision (chase gexiv2 update) - Drop shlib versions in LIB_DEPENDS - Define LICENSE (LGPL21) - Provide a better port description - Nota bene: version 0.13.1 is available Feature safe: yes Approved by: maintainer timeout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gexiv2/Makefile21
-rw-r--r--graphics/gexiv2/distinfo4
-rw-r--r--graphics/gexiv2/pkg-descr6
-rw-r--r--graphics/gexiv2/pkg-plist4
-rw-r--r--graphics/shotwell/Makefile26
-rw-r--r--graphics/shotwell/pkg-descr15
6 files changed, 40 insertions, 36 deletions
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index 5685e2c11b1b..dfb752871da0 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -1,23 +1,20 @@
-# New ports collection makefile for: gexiv2
-# Date created: Tue Sep 7 02:00:03 UTC 2010
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gexiv2
-PORTVERSION= 0.2.1
-PORTREVISION= 2
+PORTVERSION= 0.4.1
CATEGORIES= graphics
-MASTER_SITES= http://yorba.org/download/gexiv2/${PORTVERSION:R}/
+MASTER_SITES= http://yorba.org/download/${PORTNAME}/${PORTVERSION:R}/
DISTNAME= libgexiv2-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
-COMMENT= GObject-based wrapper around the Exiv2 library
+COMMENT= GObject-based wrapper around Exiv2 library
+
+LICENSE= GPLv2
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool \
gm4:${PORTSDIR}/devel/m4
-LIB_DEPENDS= exiv2.12:${PORTSDIR}/graphics/exiv2
+LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2
USE_BZIP2= yes
USE_GNOME= glib20
@@ -28,8 +25,8 @@ USE_PKGCONFIG= yes
post-patch:
@${REINPLACE_CMD} -E \
-e 's|^([[:space:]]+)m4[[:space:]]|\1gm4 |' \
- -e 's|\$$\(LIB\)/pkgconfig|libdata/pkgconfig|g' \
- ${WRKSRC}/${MAKEFILE}
+ -e 's|\$$\(LIB\)/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/${MAKEFILE}
pre-install:
@${MKDIR} ${PREFIX}/share/vala/vapi
diff --git a/graphics/gexiv2/distinfo b/graphics/gexiv2/distinfo
index 6afd2303aeaa..c51b78af3f52 100644
--- a/graphics/gexiv2/distinfo
+++ b/graphics/gexiv2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libgexiv2-0.2.1.tar.bz2) = 6279becd711de669606a95d6a2198000ef3909611b19fdfd9478a0cf265243da
-SIZE (libgexiv2-0.2.1.tar.bz2) = 24419
+SHA256 (libgexiv2-0.4.1.tar.bz2) = c51e8bae7e53866b474b51e4eef19b98385fbeaf2edac2aefd7d24ed3f7d9d6e
+SIZE (libgexiv2-0.4.1.tar.bz2) = 25484
diff --git a/graphics/gexiv2/pkg-descr b/graphics/gexiv2/pkg-descr
index 3c38c3d67f86..1c51b0ebf4cf 100644
--- a/graphics/gexiv2/pkg-descr
+++ b/graphics/gexiv2/pkg-descr
@@ -1,4 +1,4 @@
-gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes
-the basic features of Exiv2 available to GNOME applications.
-
+gexiv2 is a GObject-based wrapper around the Exiv2 library. It makes the
+basic features of Exiv2 available to GNOME applications.
+
WWW: http://trac.yorba.org/wiki/gexiv2/
diff --git a/graphics/gexiv2/pkg-plist b/graphics/gexiv2/pkg-plist
index 14560db65490..0606d2baafbb 100644
--- a/graphics/gexiv2/pkg-plist
+++ b/graphics/gexiv2/pkg-plist
@@ -1,9 +1,11 @@
include/gexiv2/gexiv2.h
+include/gexiv2/gexiv2-log.h
include/gexiv2/gexiv2-metadata.h
include/gexiv2/gexiv2-managed-stream.h
include/gexiv2/gexiv2-preview-properties.h
include/gexiv2/gexiv2-preview-image.h
-lib/libgexiv2.so.0
+include/gexiv2/gexiv2-startup.h
+lib/libgexiv2.so.1
lib/libgexiv2.so
lib/libgexiv2.la
lib/libgexiv2.a
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 93d85d408e09..76a5ce4d232a 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -1,31 +1,29 @@
-# New ports collection makefile for: shotwell
-# Date created: Tue Sep 7 02:00:03 UTC 2010
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org> et al.
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org> et al.
# $FreeBSD$
-#
PORTNAME= shotwell
PORTVERSION= 0.11.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= http://www.yorba.org/download/shotwell/${PORTVERSION:R}/
MAINTAINER= lx@FreeBSD.org
COMMENT= Open source photo manager for GNOME
+LICENSE= LGPL21
+
BUILD_DEPENDS= vala>=0.12.0:${PORTSDIR}/lang/vala
LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3 \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gee.2:${PORTSDIR}/devel/libgee \
- json-glib-1.0.0:${PORTSDIR}/devel/json-glib \
- soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ gee:${PORTSDIR}/devel/libgee \
+ json-glib-1.0:${PORTSDIR}/devel/json-glib \
+ soup-2.4:${PORTSDIR}/devel/libsoup \
gexiv2:${PORTSDIR}/graphics/gexiv2 \
- exif.12:${PORTSDIR}/graphics/libexif \
- gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
+ exif:${PORTSDIR}/graphics/libexif \
+ gphoto2:${PORTSDIR}/graphics/libgphoto2 \
webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2 \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- raw.5:${PORTSDIR}/graphics/libraw
+ unique-1.0:${PORTSDIR}/x11-toolkits/unique \
+ raw:${PORTSDIR}/graphics/libraw
USE_BZIP2= yes
USE_GETTEXT= yes
diff --git a/graphics/shotwell/pkg-descr b/graphics/shotwell/pkg-descr
index bd0ef9979e3c..9d11b3ac6c30 100644
--- a/graphics/shotwell/pkg-descr
+++ b/graphics/shotwell/pkg-descr
@@ -1,6 +1,13 @@
-[ excerpt from developer's web site with modifications ]
+Shotwell is an image organizer designed to provide personal photo management
+for the GNOME desktop environment.
+
+Shotwell can import photos and videos from a digital camera directly, group
+photos and videos automatically by date, and supports tagging. Its image
+editing features allow users to straighten, crop, eliminate red eye, and
+adjust levels and color balance. It also features an auto "enhance" option
+that will attempt to guess appropriate levels for the image.
+
+Shotwell allows users to publish their images and videos to Facebook, Flickr,
+Picasa Web Albums, Piwigo, and YouTube.
-A digital photo organizer that runs on Unix and (with limited
-features) on Windows.
-
WWW: http://www.yorba.org/shotwell/