aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2012-11-23 10:27:09 +0800
committerfluffy <fluffy@FreeBSD.org>2012-11-23 10:27:09 +0800
commit8a7473e1d75bb4c6c919ebc08d16d1fad20b36bf (patch)
tree1b3145182248407a0895231dae5bef3e61fd76ab /graphics
parent21ec1965f557ae7fe574c47f0e16a1f4c1ff4e3a (diff)
downloadfreebsd-ports-gnome-8a7473e1d75bb4c6c919ebc08d16d1fad20b36bf.tar.gz
freebsd-ports-gnome-8a7473e1d75bb4c6c919ebc08d16d1fad20b36bf.tar.zst
freebsd-ports-gnome-8a7473e1d75bb4c6c919ebc08d16d1fad20b36bf.zip
- Control of Python dependency
PR: 173772 Submitted by: Mamoru Sakaue Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/vigra/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 3014da0ec664..e60a37208d6a 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -11,6 +11,7 @@
PORTNAME= vigra
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://hci.iwr.uni-heidelberg.de/vigra/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -27,6 +28,19 @@ CMAKE_ARGS= -DDEPENDENCY_SEARCH_PREFIX:PATH=${LOCALBASE} \
USE_LDCONFIG= yes
+OPTIONS= PYTHON "Python bindings" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PYTHON)
+CONFLICTS_BUILD= python3*
+USE_PYTHON= 2.6-2.7
+.else
+CMAKE_ARGS+= -DWITH_VIGRANUMPY=0
+.endif
+
+.include <bsd.port.pre.mk>
+
# Vigra's CMakeLists.txt does not support disabling those so we hook them
# as dependencies here unconditionally (without OPTIONS=) even though if
# they are not present then Vigra/CMake will do without them (they are not
@@ -67,4 +81,4 @@ post-patch:
# FIXME: This is ugly
@${RM} ${WRKSRC}/include/vigra/*.orig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>