aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-08-10 17:07:46 +0800
committerstas <stas@FreeBSD.org>2011-08-10 17:07:46 +0800
commit9071090f0062c16303070abf7d3b0e09c1a8341e (patch)
treef8339baf2a8e093863a83dfe5054cef7fd16a699 /graphics
parenta6fed547c788dcd5351cd499e574c5465d167025 (diff)
downloadfreebsd-ports-gnome-9071090f0062c16303070abf7d3b0e09c1a8341e.tar.gz
freebsd-ports-gnome-9071090f0062c16303070abf7d3b0e09c1a8341e.tar.zst
freebsd-ports-gnome-9071090f0062c16303070abf7d3b0e09c1a8341e.zip
- Another attempt to get rid of Hg dependency.
I was in hurry last time, so have not done it properly.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/rawtherapee/files/patch-About-Linux.cmake19
-rw-r--r--graphics/rawtherapee/files/patch-CMakeLists.txt24
2 files changed, 36 insertions, 7 deletions
diff --git a/graphics/rawtherapee/files/patch-About-Linux.cmake b/graphics/rawtherapee/files/patch-About-Linux.cmake
index e5c2a0ace5c9..e84b3afc44f4 100644
--- a/graphics/rawtherapee/files/patch-About-Linux.cmake
+++ b/graphics/rawtherapee/files/patch-About-Linux.cmake
@@ -1,8 +1,19 @@
---- About-Linux.cmake.orig 2011-08-07 14:16:30.000000000 -0700
-+++ About-Linux.cmake 2011-08-07 14:19:03.000000000 -0700
-@@ -12,16 +12,8 @@
- endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+--- About-Linux.cmake.orig 2011-07-30 14:05:38.000000000 -0700
++++ About-Linux.cmake 2011-08-10 00:47:37.000000000 -0700
+@@ -1,27 +1,8 @@
+ # cmakefile executed within a makefile target
+-# we look for the hg command in this paths by order of preference
+-find_file(HG_CMD hg)
+-
+-
+-# the hg command is looked for again, at build time
+-if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(FATAL_ERROR "hg command not found!")
+-else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(STATUS "hg command found: ${HG_CMD}")
+-endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+-
set (OUT_FILE "${SRC_DIR}/AboutThisBuild.txt")
-set (SHELL "/bin/bash")
+set (SHELL "/bin/sh")
diff --git a/graphics/rawtherapee/files/patch-CMakeLists.txt b/graphics/rawtherapee/files/patch-CMakeLists.txt
index 2fe766447362..2c9296896324 100644
--- a/graphics/rawtherapee/files/patch-CMakeLists.txt
+++ b/graphics/rawtherapee/files/patch-CMakeLists.txt
@@ -1,6 +1,24 @@
---- CMakeLists.txt.orig 2011-07-31 19:25:33.000000000 -0700
-+++ CMakeLists.txt 2011-07-31 19:25:45.000000000 -0700
-@@ -322,9 +322,9 @@
+--- CMakeLists.txt.orig 2011-07-30 14:05:38.000000000 -0700
++++ CMakeLists.txt 2011-08-10 00:45:13.000000000 -0700
+@@ -250,17 +250,11 @@
+ -P ${CMAKE_CURRENT_SOURCE_DIR}/About-Linux.cmake
+ COMMENT "Creating the about file"
+ )
+- find_file(HG_CMD hg)
+
+ endif (WIN32)
+
+ add_dependencies(AboutFile Debug Release MinSizeRel RelWithDebInfo)
+
+- if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(FATAL_ERROR "hg command not found!")
+- else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(STATUS "hg command found: ${HG_CMD}")
+- endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+
+ endif (AUTOMATED_BUILD_SYSTEM)
+
+@@ -322,9 +316,9 @@
endif (OPENMP_FOUND)
endif (OPTION_OMP)