aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /graphics
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/darktable/Makefile10
-rw-r--r--graphics/enblend/Makefile3
-rw-r--r--graphics/k3d/Makefile2
-rw-r--r--graphics/libosmesa/Makefile2
-rw-r--r--graphics/libraw/Makefile2
-rw-r--r--graphics/mahotas/Makefile2
-rw-r--r--graphics/oyranos/Makefile2
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/vigra/Makefile6
9 files changed, 15 insertions, 16 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index bf6e451f3f32..71df575fdab4 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -32,15 +32,15 @@ MAN1= ${PORTNAME}.1
LDFLAGS+= -L${LOCALBASE}/lib -lintl
OPTIONS_DEFINE= GPHOTO GEO FLICKR FACEBOOK KWALLET GNOMEKEYRING RAWSPEED \
- OPENJPEG SLIDESHOW NLS GCC46
+ OPENJPEG SLIDESHOW NLS GCC
GEO_DESC= Geotagging support
FACEBOOK_DESC= Support images export to Facebook
RAWSPEED_DESC= Compile with rawspeed backend
SLIDESHOW_DESC= Build OpenGL/SDL slideshow viewer
-GCC46_DESC= Build with GCC 4.6+ (better OpenMP support)
+GCC_DESC= Build with a current version of GCC (better OpenMP support)
-OPTIONS_DEFAULT= GPHOTO RAWSPEED GCC46
+OPTIONS_DEFAULT= GPHOTO RAWSPEED GCC
.include <bsd.port.options.mk>
@@ -114,8 +114,8 @@ USES+= gettext
CMAKE_ARGS+= -DUSE_NLS:BOOL=OFF
.endif
-.if ${PORT_OPTIONS:MGCC46}
-USE_GCC= 4.6+
+.if ${PORT_OPTIONS:MGCC}
+USE_GCC= yes
# libdarktable.so has parts written in C++ (built-in rawspeed and libraw)
# and is linked to GCC 4.6's libstdc++. However CMake removes RPATH from
# this library, and libstdc++ from base (GCC 4.2.1) is pulled at runtime,
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 82ad65afdafc..8b62d52c582d 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -29,8 +29,7 @@ CONFIGURE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo"
# GCC 4.2 has some problems, see
# http://groups.google.com/group/hugin-ptx/browse_thread/thread/725b1581c9889e37/50abe3387d61541a#50abe3387d61541a
-# Gerald Pfeifer <gerald@pfeifer.com> asked to use 4.4+ instead of 4.3+
-USE_GCC= 4.4+
+USE_GCC= yes
USE_GL= glew glut
GNU_CONFIGURE= yes
CONFIGURE_ENV+= "LIBS=-lboost_system"
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index edb627d9aea6..159d329919cf 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -37,7 +37,7 @@ USE_BZIP2= yes
USE_GL= glu
USE_GNOME= gtksourceview2
USE_DOS2UNIX= *.hpp
-USE_GCC= 4.6+
+USE_GCC= yes
USE_PYTHON= yes
USES= cmake:outsource gettext
CMAKE_ARGS= -DK3D_INTL_INCLUDE_DIRS:STRING="-I${LOCALBASE}/include" \
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index 72c7d4ff9f8f..a5842bc09136 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -45,7 +45,7 @@ CC= /usr/bin/clang
CXX= /usr/bin/clang++
CPP= /usr/bin/clang-cpp
.else
-USE_GCC=4.6+
+USE_GCC=yes
.endif
.endif
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
index 64dae9ac65db..b90092dc3c21 100644
--- a/graphics/libraw/Makefile
+++ b/graphics/libraw/Makefile
@@ -42,7 +42,7 @@ CFLAGS+= -O3
.endif
.if ${PORT_OPTIONS:MOPENMP}
-USE_GCC= 4.6+
+USE_GCC= yes
CONFIGURE_ARGS+=--enable-openmp
.else
CONFIGURE_ARGS+=--disable-openmp
diff --git a/graphics/mahotas/Makefile b/graphics/mahotas/Makefile
index b4dbbff38fb8..2a0b6dd501e0 100644
--- a/graphics/mahotas/Makefile
+++ b/graphics/mahotas/Makefile
@@ -13,7 +13,7 @@ COMMENT= Computer vision and image processing library for Python
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= freeimage:${PORTSDIR}/graphics/freeimage
-USE_GCC= 4.6+
+USE_GCC= yes
USE_PYTHON= 2.5+
USE_PYDISTUTILS= easy_install
PYEASYINSTALL_ARCHDEP= yes
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 24589df70375..070e8bdccff3 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -45,7 +45,7 @@ MAN3= oyranos-config.3 oyranos.3
CC= /usr/bin/clang
CXX= /usr/bin/clang++
.else
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 0c7ba8c7334c..690d03f53315 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -27,7 +27,7 @@ USE_XZ= yes
USE_GNOME= gtk20 glib20
USE_LDCONFIG= yes
# base GCC and clang in 9.1-RELEASE are insufficient:
-USE_GCC= 4.6+
+USE_GCC= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
CXXFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 8b10a591f3ac..eb17de357069 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -44,7 +44,7 @@ CMAKE_ARGS+= -DWITH_OPENEXR=0
.if ${PORT_OPTIONS:MNUMPY}
CONFLICTS_BUILD= python3*
CMAKE_ARGS+= -DWITH_VIGRANUMPY=1
-USE_GCC= 4.6+
+USE_GCC= yes
USE_FORTRAN= yes
USE_PYTHON= 2.6-2.7
BUILD_DEPENDS+= nosetests:${PORTSDIR}/devel/py-nose
@@ -92,8 +92,8 @@ pre-everything::
.if ${PORT_OPTIONS:MNUMPY}
@${ECHO} ""
@${ECHO} "* BEWARE!"
- @${ECHO} "* Using py-NumPY implies Fortran and GCC4.6+ as hard dependencies"
- @${ECHO} "* and require to all ports, depended on vigra, set USE_GCC=4.6+"
+ @${ECHO} "* Using py-NumPY implies Fortran and GCC 4.6+ as hard dependencies"
+ @${ECHO} "* and require all ports, depending on vigra, to set USE_GCC=yes"
@${ECHO} ""
.endif