aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-12-26 03:20:24 +0800
committermiwi <miwi@FreeBSD.org>2009-12-26 03:20:24 +0800
commit96aa6341c5f2a308f4a5c4c9f3d1fa0ebc2fff82 (patch)
tree465071573f26ee783a798068ac53359b22a6a6f0 /graphics
parentc2525557ee3bf07488e23c48b6d723a12e98d111 (diff)
downloadfreebsd-ports-gnome-96aa6341c5f2a308f4a5c4c9f3d1fa0ebc2fff82.tar.gz
freebsd-ports-gnome-96aa6341c5f2a308f4a5c4c9f3d1fa0ebc2fff82.tar.zst
freebsd-ports-gnome-96aa6341c5f2a308f4a5c4c9f3d1fa0ebc2fff82.zip
Auto Adjust Photo is a small command-line image manipulation tool that
allows the user to easily correct family photos. It tries to make the picture look better. The program does this by analyzing the input image and then sets the most optimal contrast, gamma, color balance and saturation for it. WWW: http://log69.com/aaphoto_en.html PR: ports/141949 Submitted by: Andras Horvath <han at log69.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/aaphoto/Makefile33
-rw-r--r--graphics/aaphoto/distinfo3
-rw-r--r--graphics/aaphoto/pkg-descr7
4 files changed, 44 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 0f92f4008f71..124c409e0db2 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -18,6 +18,7 @@
SUBDIR += SciPlot
SUBDIR += a2png
SUBDIR += aalib
+ SUBDIR += aaphoto
SUBDIR += acidwarp
SUBDIR += agave
SUBDIR += agg
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
new file mode 100644
index 000000000000..057c4d2fad87
--- /dev/null
+++ b/graphics/aaphoto/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: aaphoto
+# Date created: 2009-12-24
+# Whom: Andras Horvath <han@log69.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aaphoto
+PORTVERSION= 0.32
+CATEGORIES= graphics
+MASTER_SITES= http://log69.com/downloads/
+DISTNAME= ${PORTNAME}_sources_v${PORTVERSION}
+
+MAINTAINER= han@log69.com
+COMMENT= Auto Adjust Photo, automatic color correction of photos
+
+LIB_DEPENDS= jasper:${PORTSDIR}/graphics/jasper \
+ png:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}
+
+PLIST_FILES= bin/aaphoto
+
+do-install:
+.for FILE in aaphoto
+ ${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/aaphoto/distinfo b/graphics/aaphoto/distinfo
new file mode 100644
index 000000000000..cfbee3a26b6e
--- /dev/null
+++ b/graphics/aaphoto/distinfo
@@ -0,0 +1,3 @@
+MD5 (aaphoto_sources_v0.32.tar.gz) = 06167ec2dd7047583300da928010f74e
+SHA256 (aaphoto_sources_v0.32.tar.gz) = 1c8cd42f0a045f2998d250992e28265e6c395d13ee76d807456801aeee20f904
+SIZE (aaphoto_sources_v0.32.tar.gz) = 257330
diff --git a/graphics/aaphoto/pkg-descr b/graphics/aaphoto/pkg-descr
new file mode 100644
index 000000000000..f95adac87a32
--- /dev/null
+++ b/graphics/aaphoto/pkg-descr
@@ -0,0 +1,7 @@
+Auto Adjust Photo is a small command-line image manipulation tool that
+allows the user to easily correct family photos. It tries to make the
+picture look better. The program does this by analyzing the input image
+and then sets the most optimal contrast, gamma, color balance and
+saturation for it.
+
+WWW: http://log69.com/aaphoto_en.html