aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-10-19 11:00:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-10-19 11:00:27 +0800
commit9c3034fc6a43a5dc762e9a8e9319424a28bbb4a1 (patch)
tree0987bc381e07f3b6e0b03216023b5d9f1d3b6575 /graphics
parent99d21637c40ebe452f4f57aa7bdf4a002c0cf6c9 (diff)
downloadfreebsd-ports-gnome-9c3034fc6a43a5dc762e9a8e9319424a28bbb4a1.tar.gz
freebsd-ports-gnome-9c3034fc6a43a5dc762e9a8e9319424a28bbb4a1.tar.zst
freebsd-ports-gnome-9c3034fc6a43a5dc762e9a8e9319424a28bbb4a1.zip
- Support staging
Diffstat (limited to 'graphics')
-rw-r--r--graphics/structuresynth/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
index 694b46f51d86..9e6d601718c0 100644
--- a/graphics/structuresynth/Makefile
+++ b/graphics/structuresynth/Makefile
@@ -17,7 +17,6 @@ USE_QT4= qmake_build corelib gui opengl moc_build rcc_build xml script
WRKSRC= ${WRKDIR}/structure-synth
USE_DOS2UNIX= *.cpp *.h
-NO_STAGE= yes
post-extract:
@${MV} "${WRKDIR}/Structure Synth Source Code" ${WRKSRC}
@${RM} -rf ${WRKSRC}/Examples/DontDeploy
@@ -34,13 +33,12 @@ do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/structure-synth ${PREFIX}/bin/
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "Examples Misc" ${DATADIR}/
- ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_PROGRAM} ${WRKSRC}/structure-synth ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "Examples Misc" ${STAGEDIR}${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/structure-synth.desktop \
- ${PREFIX}/share/applications/
+ ${STAGEDIR}${PREFIX}/share/applications/
${INSTALL_DATA} ${WRKSRC}/images/fileicons/StructureSynth-256.png \
- ${PREFIX}/share/pixmaps/structure-synth.png
+ ${STAGEDIR}${PREFIX}/share/pixmaps/structure-synth.png
.include <bsd.port.mk>