aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-25 22:06:30 +0800
committermakc <makc@FreeBSD.org>2013-03-25 22:06:30 +0800
commit9e2d75a022714765fe2ab8c51fd2862f6ad12ed9 (patch)
tree99d052079d69749d9d4cf44ea475663d31fc235a /graphics
parent1a11f7a098337b7818e5bae5107c9c54232ff720 (diff)
downloadfreebsd-ports-gnome-9e2d75a022714765fe2ab8c51fd2862f6ad12ed9.tar.gz
freebsd-ports-gnome-9e2d75a022714765fe2ab8c51fd2862f6ad12ed9.tar.zst
freebsd-ports-gnome-9e2d75a022714765fe2ab8c51fd2862f6ad12ed9.zip
- Add dependence on libglut [1]
- Convert to new option framework - Convert to USES/PKG_CONFIG - Pass more switches to configure script in order to avoid auto-detection - Trim Makefile header - Update and reformat description PR: ports/175963 [1] Submitted by: pawel
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libcaca/Makefile47
-rw-r--r--graphics/libcaca/pkg-descr12
2 files changed, 32 insertions, 27 deletions
diff --git a/graphics/libcaca/Makefile b/graphics/libcaca/Makefile
index 3a48ca3d099e..444ab959a345 100644
--- a/graphics/libcaca/Makefile
+++ b/graphics/libcaca/Makefile
@@ -1,20 +1,18 @@
-# New ports collection makefile for: libcaca
-# Date created: 11 January 2004
-# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
-#
+# Created by: Vincent Tantardini <vinc@FreeBSD-fr.org>
# $FreeBSD$
-#
PORTNAME= libcaca
DISTVERSION= 0.99.beta18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://caca.zoy.org/raw-attachment/wiki/libcaca/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Graphics library that outputs text instead of pixels
-USE_GNOME= gnomehack ltverhack pkgconfig
+USES= pathfix
+USE_GNOME= ltverhack
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --disable-doc \
@@ -22,28 +20,35 @@ CONFIGURE_ARGS= --disable-doc \
--disable-java \
--disable-csharp \
--disable-ruby \
- --disable-python
+ --disable-python \
+ --disable-cppunit \
+ --disable-zzuf
DOCS= AUTHORS COPYING COPYING.GPL COPYING.LGPL ChangeLog NEWS \
NOTES README THANKS
MAN1= caca-config.1 cacademo.1 cacafire.1 cacaplay.1 cacaserver.1 \
cacaview.1 img2txt.1
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--disable-x11
-.else
+OPTIONS_DEFINE= X11 IMLIB2 SLANG DOCS
+OPTIONS_DEFAULT= X11 IMLIB2
+X11_DESC= X11 and OpenGL support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
+USE_GL= glut
+.else
+CONFIGURE_ARGS+=--disable-x11 --disable-gl
.endif
-.if defined(WITHOUT_IMLIB2)
-CONFIGURE_ARGS+=--disable-imlib2
-.else
+.if ${PORT_OPTIONS:MIMLIB2}
USE_EFL+= imlib2
+.else
+CONFIGURE_ARGS+=--disable-imlib2
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_SLANG)
+.if ${PORT_OPTIONS:MSLANG}
LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
CONFIGURE_ARGS+=--enable-slang
.else
@@ -56,12 +61,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|: install-docDATA|:|g ; s| csharp||g' \
${WRKSRC}/Makefile.in
-.ifndef (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
-.for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/libcaca/pkg-descr b/graphics/libcaca/pkg-descr
index 24d03c95b260..fb61c92ed0b6 100644
--- a/graphics/libcaca/pkg-descr
+++ b/graphics/libcaca/pkg-descr
@@ -1,7 +1,9 @@
-The libcaca library is a graphics library that outputs text instead of
-pixels, so that it can work on older video cards or text terminals. It
-is not unlike the famous AAlib library. It also have 6 available colours
-for character output, dithering of colour images and basic sprite
-primitives.
+libcaca is a graphics library that outputs text instead of pixels,
+so that it can work on older video cards or text terminals. It is
+not unlike the famous AAlib library, with the following improvements:
+ * Unicode support
+ * 2048 available colours (some devices can only handle 16)
+ * dithering of colour images
+ * advanced text canvas operations (blitting, rotations)
WWW: http://caca.zoy.org/