aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-15 14:21:13 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-15 14:21:13 +0800
commita1f7a7b4126b688009ebfece767158ceac4d390b (patch)
tree97e0c59c3b7472bfc1c2f881a49d3e233820e997 /graphics
parentca8f54194cfeb036237864e7118777ea36b026b4 (diff)
downloadfreebsd-ports-gnome-a1f7a7b4126b688009ebfece767158ceac4d390b.tar.gz
freebsd-ports-gnome-a1f7a7b4126b688009ebfece767158ceac4d390b.tar.zst
freebsd-ports-gnome-a1f7a7b4126b688009ebfece767158ceac4d390b.zip
- update to 0.8.10
- use OPTIONS_DEFINE - take maintainership
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gnash/Makefile109
-rw-r--r--graphics/gnash/distinfo4
-rw-r--r--graphics/gnash/files/patch-configure13
-rw-r--r--graphics/gnash/files/patch-macros-ffmpeg.m415
-rw-r--r--graphics/gnash/files/patch-plugin-npapi-Makefile.in11
-rw-r--r--graphics/gnash/pkg-plist45
6 files changed, 84 insertions, 113 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 6fe5a6912629..97735424ffe5 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,25 +6,25 @@
#
PORTNAME= gnash
-PORTVERSION= 0.8.9
-PORTREVISION= 4
+PORTVERSION= 0.8.10
CATEGORIES= graphics
-MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/ \
- http://mirror.amdmi3.ru/distfiles/
+MASTER_SITES= GNU/${PORTNAME}/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNU Flash movie player
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
jpeg.11:${PORTSDIR}/graphics/jpeg \
curl.6:${PORTSDIR}/ftp/curl \
gif.5:${PORTSDIR}/graphics/giflib \
- speex.1:${PORTSDIR}/audio/speex
+ speex.1:${PORTSDIR}/audio/speex \
+ nspr4:${PORTSDIR}/devel/nspr
CONFLICTS= gnash-devel-[0-9]*
USE_BZIP2= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
WANT_SDL= yes
WANT_GNOME= yes
@@ -58,22 +58,27 @@ MAN1= cygnal.1 findmicrophones.1 findwebcams.1 \
flvdumper.1 gnash.1 gprocessor.1 \
rtmpget.1 soldumper.1
-OPTIONS= PLUGIN "Enable browser plugin" on \
- CYGNAL "Enable Cygnal media server" off \
- GTK "GUI: GTK (required for Mozilla/Firefox plugin)" on \
- KDE "GUI: KDE 3.x (required for Konqueror 3.x plugin)" off \
- KDE4 "GUI: KDE 4.x (required for Konqueror 4.x plugin)" off \
- AGG "Renderer: AGG" on \
- OPENGL "Renderer: OpenGL (broken)" off \
- CAIRO "Renderer: Cairo (experimental)" off \
- VAAPI "Enable VAAPI support (requires FFMPEG)" off \
- FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
- GSTREAMER "Media handler: GStreamer" off
+OPTIONS_DEFINE= PLUGIN CYGNAL VAAPI FFMPEG GSTREAMER
+OPTIONS_SINGLE= GUI RENDERER
+OPTIONS_SINGLE_GUI= GTK2 KDE3 KDE4
+OPTIONS_SINGLE_RENDERER=AGG OPENGL CAIRO
+#OPTIONS_SINGLE_MEDIA= FFMPEG GSTREAMER
+OPTIONS_DEFAULT=GTK2 PLUGIN AGG FFMPEG VAAPI
+
+NO_OPTIONS_SORT=yes
+PLUGIN_DESC= Enable browser plugin
+CYGNAL_DESC= Enable Cygnal media server
+AGG_DESC= Enable AGG renderer
+OPENGL_DESC= Enable OpenGL renderer (broken)
+CAIRO_DESC= Enable Cairo renderer (experimental)
+FFMPEG_DESC= Enable ffmpeg media handler
+GSTREAMER_DESC= Enable GStreamer media handler
+VAAPI_DESC= Enable VAAPI support (requires FFMPEG)
.include <bsd.port.options.mk>
# Cygnal option processing
-.if defined(WITH_CYGNAL)
+.if ${PORT_OPTIONS:MCYGNAL}
PLIST_SUB+= CYGNAL=""
CONFIGURE_ARGS+= --enable-cygnal
CONFIG_FILES+= cygnalrc
@@ -83,7 +88,7 @@ CONFIGURE_ARGS+= --disable-cygnal
.endif
# NLS option processing (not sure if --disable-nls actually has any effect)
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -94,7 +99,7 @@ PLIST_SUB+= NLS="@comment "
#
# Plugin configuration
#
-.if !defined(WITHOUT_GTK) && !defined(WITHOUT_PLUGIN)
+.if ${PORT_OPTIONS:MGTK2} && ${PORT_OPTIONS:MPLUGIN}
USE_WEBPLUGINS= native
WEBPLUGINS_FILES= libgnashplugin.so
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
@@ -107,15 +112,15 @@ PLIST_SUB+= NPAPI="@comment "
CONFIGURE_ARGS+= --disable-npapi
.endif
-.if defined(WITH_KDE) && !defined(WITHOUT_PLUGIN)
-PLIST_SUB+= KPARTS=""
+.if ${PORT_OPTIONS:MKDE3} && ${PORT_OPTIONS:MPLUGIN}
+PLIST_SUB+= KPARTS3=""
USE_LDCONFIG+= ${PREFIX}/lib/kde3
.else
-PLIST_SUB+= KPARTS="@comment "
+PLIST_SUB+= KPARTS3="@comment "
CONFIGURE_ARGS+= --disable-kparts3
.endif
-.if defined(WITH_KDE4) && !defined(WITHOUT_PLUGIN)
+.if ${PORT_OPTIONS:MKDE4} && ${PORT_OPTIONS:MPLUGIN}
PLIST_SUB+= KPARTS4=""
USE_LDCONFIG+= ${KDE4_PREFIX}/lib/kde4
CONFIGURE_ARGS+= --with-kde4_prefix=${PREFIX}/kde4
@@ -129,8 +134,8 @@ CONFIGURE_ARGS+= --disable-kparts4
#
GNASH_GUIS=
-.if !defined(WITHOUT_GTK)
-USE_GNOME= gtk20
+.if ${PORT_OPTIONS:MGTK2}
+USE_GNOME= gtk20 atk gconf2
GNASH_GUIS+= gtk
PLIST_SUB+= GTK=""
MAN1+= gnash-gtk-launcher.1 gtk-gnash.1
@@ -138,7 +143,7 @@ MAN1+= gnash-gtk-launcher.1 gtk-gnash.1
PLIST_SUB+= GTK="@comment "
.endif
-.if defined(WITH_KDE)
+.if ${PORT_OPTIONS:MKDE3}
GNASH_GUIS+= kde3
PLIST_SUB+= KDE=""
USE_KDELIBS_VER=3
@@ -146,23 +151,23 @@ USE_KDELIBS_VER=3
PLIST_SUB+= KDE="@comment "
.endif
-.if defined(WITH_KDE4)
+.if ${PORT_OPTIONS:MKDE4}
GNASH_GUIS+= kde4
PLIST_SUB+= KDE4=""
USE_QT4= moc_build
QT_NONSTANDARD= yes
USE_KDE4= kdehier kdelibs
CONFIGURE_ENV+= KDE4_CONFIG="${KDE4_PREFIX}/bin/kde4-config"
-. if exists(${LOCALBASE}/lib/libkdeui.so)
+.if exists(${LOCALBASE}/lib/libkdeui.so)
IGNORE= KDE4 GUI can't be built when KDE3 is installed. Please rerun 'make config' and disable KDE4 GUI or deinstall kdelibs-3
-. endif
+.endif
MAN1+= gnash-qt-launcher.1 kde4-gnash.1
.else
PLIST_SUB+= KDE4="@comment "
.endif
-.if defined(WITH_KDE) && defined defined(WITH_KDE4)
-IGNORE= KDE and KDE4 GUIs are mutually exclusive. Please rerun 'make config' and disable one of these
+.if ${PORT_OPTIONS:MKDE3} && ${PORT_OPTIONS:MKDE4}
+IGNORE= KDE3 and KDE4 GUIs are mutually exclusive. Please rerun 'make config' and disable one of these
.endif
.if ${GNASH_GUIS} == ""
@@ -176,23 +181,23 @@ CONFIGURE_ARGS+=--enable-gui=`${ECHO} ${GNASH_GUIS} | ${TR} ' ' ,`
#
GNASH_RENDERERS=
-.if defined(WITH_AGG)
+.if ${PORT_OPTIONS:MAGG}
LIB_DEPENDS+= agg.2:${PORTSDIR}/graphics/agg
GNASH_RENDERERS+= agg
.endif
-.if defined(WITH_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
USE_GL= yes
GNASH_RENDERERS+= ogl
-. if !defined(WITHOUT_GTK)
+.if ${PORT_OPTIONS:MGTK2}
LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
-. endif
+.endif
.endif
-.if defined(WITH_CAIRO)
-. if defined(WITH_KDE) || defined(WITH_KDE4)
+.if ${PORT_OPTIONS:MCAIRO}
+.if ${PORT_OPTIONS:MKDE3} || ${PORT_OPTIONS:MKDE4}
IGNORE= doesn't support Cairo renderer with KDE/KDE4 gui. Please rerun 'make config' and select different renderer or disable KDE/KDE4 GUIs
-. endif
+.endif
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
GNASH_RENDERERS+= cairo
.endif
@@ -206,10 +211,10 @@ CONFIGURE_ARGS+= --enable-renderer=`${ECHO} ${GNASH_RENDERERS} | ${TR} ' ' ,`
#
# Hardware acceleration options processing
#
-.if defined(WITH_VAAPI)
-. if !defined(WITH_FFMPEG)
+.if ${PORT_OPTIONS:MVAAPI}
+.if empty(PORT_OPTIONS:MFFMPEG)
IGNORE= VAAPI currently works only with FFMPEG. Please rerun 'make config' and enable FFMPEG.
-. endif
+.endif
LIB_DEPENDS+= va.1:${PORTSDIR}/multimedia/libva
PLIST_SUB+= VAAPI=""
.else
@@ -220,21 +225,20 @@ PLIST_SUB+= VAAPI="@comment "
#
# Media handler options processing
#
-.if defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER)
+.if ${PORT_OPTIONS:MFFMPEG} && empty(PORT_OPTIONS:MGSTREAMER)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-media=ffmpeg
USE_SDL+= sdl
-.elif !defined(WITH_FFMPEG) && defined(WITH_GSTREAMER)
+.elif empty(PORT_OPTIONS:MFFMPEG) && ${PORT_OPTIONS:MGSTREAMER}
USE_GSTREAMER= yes
CONFIGURE_ARGS+= --enable-media=gst
USE_SDL+= sdl
-.elif !defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER)
+.elif empty(PORT_OPTIONS:MFFMPEG) && empty(PORT_OPTIONS:MGSTREAMER)
CONFIGURE_ARGS+= --enable-media=none
-.else
IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer)
.endif
-.if defined(WITH_GSTREAMER)
+.if ${PORT_OPTIONS:MGSTREAMER}
PLIST_SUB+= GSTREAMER=""
.else
PLIST_SUB+= GSTREAMER="@comment "
@@ -243,7 +247,7 @@ PLIST_SUB+= GSTREAMER="@comment "
.include <bsd.port.pre.mk>
pre-everything::
-.if defined(WITH_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
@${ECHO_CMD} "OpenGL support is currently broken (Gnash hangs using 100% CPU). Use at your own risk"
@sleep 3
.endif
@@ -270,18 +274,17 @@ post-install:
${PREFIX}/etc/${conf}; \
fi
.endfor
-
-.if !defined(WITHOUT_PLUGIN)
-.if !defined(WITHOUT_GTK)
+.if ${PORT_OPTIONS:MPLUGIN}
+.if ${PORT_OPTIONS:MGTK2}
${MKDIR} ${WEBPLUGINS_DIR}
@cd ${INSTALL_WRKSRC}/plugin && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install-plugin
.endif
-.if defined(WITH_KDE)
+.if ${PORT_OPTIONS:MKDE3}
@cd ${INSTALL_WRKSRC}/plugin/klash && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install-plugin
.endif
-.if defined(WITH_KDE4)
+.if ${PORT_OPTIONS:MKDE4}
@cd ${INSTALL_WRKSRC}/plugin/klash4 && \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install-plugin
.endif
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index 14580621eb67..b84845eff6e7 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnash-0.8.9.tar.bz2) = f90dbdc6f03d787b239b9edacbea077b46d69ae9d85f08af23f256af389c48bd
-SIZE (gnash-0.8.9.tar.bz2) = 3777140
+SHA256 (gnash-0.8.10.tar.bz2) = 9625072e45df92baa2c28fc9999d4e2deb66bc827530baedfad2e4e2292d1224
+SIZE (gnash-0.8.10.tar.bz2) = 4238106
diff --git a/graphics/gnash/files/patch-configure b/graphics/gnash/files/patch-configure
index e9283fec0511..6e15aee6dc61 100644
--- a/graphics/gnash/files/patch-configure
+++ b/graphics/gnash/files/patch-configure
@@ -1,18 +1,5 @@
--- configure.orig 2011-03-18 09:50:30.000000000 -0400
+++ configure 2011-07-23 14:50:23.436294372 -0400
-@@ -9373,9 +9373,9 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking ffmpeg version" >&5
- $as_echo_n "checking ffmpeg version... " >&6; }
-
-- ffmpeg_major_version=`$EGREP "define LIBAVCODEC_VERSION_MAJOR " ${avcodec_h} | sed -e "s%[^0-9]%%g"`
-- ffmpeg_minor_version=`$EGREP "define LIBAVCODEC_VERSION_MINOR " ${avcodec_h} | sed -e "s%[^0-9]%%g"`
-- ffmpeg_micro_version=`$EGREP "define LIBAVCODEC_VERSION_MICRO " ${avcodec_h} | sed -e "s%[^0-9]%%g"`
-+ ffmpeg_major_version=`$EGREP "define LIBAVCODEC_VERSION_MAJOR " ${ffmpeg_top_incl}/libavcodec/version.h | sed -e "s%[^0-9]%%g"`
-+ ffmpeg_minor_version=`$EGREP "define LIBAVCODEC_VERSION_MINOR " ${ffmpeg_top_incl}/libavcodec/version.h | sed -e "s%[^0-9]%%g"`
-+ ffmpeg_micro_version=`$EGREP "define LIBAVCODEC_VERSION_MICRO " ${ffmpeg_top_incl}/libavcodec/version.h | sed -e "s%[^0-9]%%g"`
-
- if test x"${ffmpeg_major_version}" != x ; then
-
@@ -27778,6 +27778,11 @@
esac
fi
diff --git a/graphics/gnash/files/patch-macros-ffmpeg.m4 b/graphics/gnash/files/patch-macros-ffmpeg.m4
deleted file mode 100644
index 6e7a266fcf89..000000000000
--- a/graphics/gnash/files/patch-macros-ffmpeg.m4
+++ /dev/null
@@ -1,15 +0,0 @@
---- macros/ffmpeg.m4.orig 2011-06-24 09:51:50.606673957 +0200
-+++ macros/ffmpeg.m4 2011-06-24 09:52:10.371550401 +0200
-@@ -184,9 +184,9 @@
-
- AC_MSG_CHECKING([ffmpeg version])
-
-- ffmpeg_major_version=`$EGREP "define LIBAVCODEC_VERSION_MAJOR " ${avcodec_h} | sed -e "s%[[^0-9]]%%g"`
-- ffmpeg_minor_version=`$EGREP "define LIBAVCODEC_VERSION_MINOR " ${avcodec_h} | sed -e "s%[[^0-9]]%%g"`
-- ffmpeg_micro_version=`$EGREP "define LIBAVCODEC_VERSION_MICRO " ${avcodec_h} | sed -e "s%[[^0-9]]%%g"`
-+ ffmpeg_major_version=`$EGREP "define LIBAVCODEC_VERSION_MAJOR " ${ffmpeg_top_incl}/libavcodec/version.h | sed -e "s%[[^0-9]]%%g"`
-+ ffmpeg_minor_version=`$EGREP "define LIBAVCODEC_VERSION_MINOR " ${ffmpeg_top_incl}/libavcodec/version.h | sed -e "s%[[^0-9]]%%g"`
-+ ffmpeg_micro_version=`$EGREP "define LIBAVCODEC_VERSION_MICRO " ${ffmpeg_top_incl}/libavcodec/version.h | sed -e "s%[[^0-9]]%%g"`
-
- if test x"${ffmpeg_major_version}" != x ; then
-
diff --git a/graphics/gnash/files/patch-plugin-npapi-Makefile.in b/graphics/gnash/files/patch-plugin-npapi-Makefile.in
deleted file mode 100644
index 4de5d901c5b8..000000000000
--- a/graphics/gnash/files/patch-plugin-npapi-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugin/npapi/Makefile.in.orig 2011-06-16 18:47:41.180628330 -0400
-+++ plugin/npapi/Makefile.in 2011-06-16 18:48:21.950238296 -0400
-@@ -633,7 +633,7 @@
- -I$(top_srcdir)/libcore/parser -I$(top_srcdir)/libbase \
- -I$(top_srcdir)/librender -I$(srcdir)/mozilla-sdk \
- $(NPAPI_CFLAGS) $(X11_CFLAGS) $(GLIB_CFLAGS) $(NULL) \
-- $(am__append_1) $(am__append_2) $(am__append_3)
-+ $(am__append_1) $(am__append_2) $(am__append_3) $(BOOST_CFLAGS)
-
- # AM_CXXFLAGS = $(AM_CPPFLAGS)
- noinst_HEADERS = plugin.h mozilla-sdk/pluginbase.h \
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index a3e7c6fb21e7..6a14737b0147 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -61,7 +61,6 @@ include/gnash/Point_as.h
include/gnash/RTMP.h
include/gnash/Range2d.h
include/gnash/Rectangle_as.h
-include/gnash/Renderer.h
include/gnash/SWFCtype.h
include/gnash/SharedMem.h
include/gnash/SimpleBuffer.h
@@ -145,6 +144,7 @@ include/gnash/asobj/TextFormat_as.h
include/gnash/asobj/TextSnapshot_as.h
include/gnash/asobj/UserFunction.h
include/gnash/asobj/Video.h
+include/gnash/asobj/Video_as.h
include/gnash/asobj/XMLNode_as.h
include/gnash/asobj/XMLSocket_as.h
include/gnash/asobj/XML_as.h
@@ -165,7 +165,10 @@ include/gnash/geom_pkg.h
include/gnash/getclocktime.hpp
include/gnash/gettext.h
include/gnash/gmemory.h
-include/gnash/jemtree.h
+include/gnash/jemalloc.h
+include/gnash/jemalloc_gnash.h
+include/gnash/jemalloc_rb.h
+include/gnash/jemalloc_types.h
include/gnash/log.h
include/gnash/net_pkg.h
include/gnash/noseek_fd_adapter.h
@@ -173,7 +176,6 @@ include/gnash/parser/movie_definition.h
include/gnash/rc.h
include/gnash/ref_counted.h
include/gnash/sharedlib.h
-include/gnash/smart_ptr.h
include/gnash/snappingrange.h
include/gnash/string_table.h
include/gnash/text_pkg.h
@@ -189,11 +191,11 @@ include/gnash/vm/SafeStack.h
include/gnash/vm/VM.h
include/gnash/vm/fn_call.h
include/gnash/zlib_adapter.h
-%%KPARTS%%share/apps/klash/pluginsinfo
-%%KPARTS%%share/apps/klash/klashpartui.rc
-%%KPARTS%%share/services/klash_part.desktop
-%%KPARTS%%lib/kde3/libklashpart.la
-%%KPARTS%%lib/kde3/libklashpart.so
+%%KPARTS3%%share/apps/klash/pluginsinfo
+%%KPARTS3%%share/apps/klash/klashpartui.rc
+%%KPARTS3%%share/services/klash_part.desktop
+%%KPARTS3%%lib/kde3/libklashpart.la
+%%KPARTS3%%lib/kde3/libklashpart.so
%%KPARTS4%%kde4/share/apps/klash/pluginsinfo
%%KPARTS4%%kde4/share/apps/klash/klashpartui.rc
%%KPARTS4%%kde4/share/kde4/services/klash_part.desktop
@@ -206,6 +208,9 @@ lib/gnash/libgnashbase-%%GNASHVER%%.so
lib/gnash/libgnashbase.so
lib/gnash/libgnashcore-%%GNASHVER%%.so
lib/gnash/libgnashcore.so
+lib/gnash/libgnashdevice-%%GNASHVER%%.so
+lib/gnash/libgnashdevice.la
+lib/gnash/libgnashdevice.so
lib/gnash/libgnashmedia-%%GNASHVER%%.so
lib/gnash/libgnashmedia.so
%%CYGNAL%%lib/gnash/libgnashnet-%%GNASHVER%%.so
@@ -214,35 +219,37 @@ lib/gnash/libgnashrender-%%GNASHVER%%.so
lib/gnash/libgnashrender.so
lib/gnash/libgnashsound-%%GNASHVER%%.so
lib/gnash/libgnashsound.so
-%%VAAPI%%lib/gnash/libgnashvaapi-%%GNASHVER%%.so
-%%VAAPI%%lib/gnash/libgnashvaapi.la
-%%VAAPI%%lib/gnash/libgnashvaapi.so
libdata/pkgconfig/gnash.pc
%%GTK%%share/applications/gnash.desktop
%%KDE4%%share/applications/klash.desktop
-%%DATADIR%%/doc/gnash/C/gnashref.html
-%%DATADIR%%/doc/gnash/C/gnashuser.html
-%%DATADIR%%/doc/gnash/C/images/rtmp.png
%%DATADIR%%/GnashG.png
%%DATADIR%%/gnash-splash.swf
%%DATADIR%%/gnash_128_96.ico
+%%DOCSDIR%%/gnashref.html
+%%DOCSDIR%%/gnashuser.html
+%%DOCSDIR%%/images/rtmp.png
%%GTK%%share/icons/hicolor/32x32/apps/gnash.xpm
%%KDE4%%share/icons/hicolor/32x32/apps/klash.xpm
share/locale/cs/LC_MESSAGES/gnash.mo
+share/locale/da/LC_MESSAGES/gnash.mo
share/locale/de/LC_MESSAGES/gnash.mo
+share/locale/en_GB/LC_MESSAGES/gnash.mo
+share/locale/el/LC_MESSAGES/gnash.mo
share/locale/es/LC_MESSAGES/gnash.mo
share/locale/fi/LC_MESSAGES/gnash.mo
share/locale/fr/LC_MESSAGES/gnash.mo
share/locale/it/LC_MESSAGES/gnash.mo
share/locale/ja/LC_MESSAGES/gnash.mo
+share/locale/km/LC_MESSAGES/gnash.mo
+share/locale/ne/LC_MESSAGES/gnash.mo
+share/locale/ru/LC_MESSAGES/gnash.mo
+share/locale/zh_TW/LC_MESSAGES/gnash.mo
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
@dirrmtry share/icons/hicolor/32x32/apps
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
-@dirrm %%DATADIR%%/doc/gnash/C/images
-@dirrm %%DATADIR%%/doc/gnash/C
-@dirrm %%DATADIR%%/doc/gnash
-@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrm lib/gnash
@@ -252,6 +259,6 @@ share/locale/ja/LC_MESSAGES/gnash.mo
@dirrm include/gnash/parser
@dirrm include/gnash/asobj
@dirrm include/gnash
-%%KPARTS%%@dirrm share/apps/klash
+%%KPARTS3%%@dirrm share/apps/klash
%%KPARTS4%%@dirrm kde4/share/apps/klash
%%NPAPI%%@dirrmtry %%WEBPLUGINS_DIR%%