aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-05-12 01:58:09 +0800
committerdinoex <dinoex@FreeBSD.org>2011-05-12 01:58:09 +0800
commita210caa700bafd0e1925d46f4a7fc2c171fcc139 (patch)
tree3c350e94e34104166a66d4de994b5518c6092dee /graphics
parent9a6f18de934b28663f19985037d1be62ee4cd599 (diff)
downloadfreebsd-ports-gnome-a210caa700bafd0e1925d46f4a7fc2c171fcc139.tar.gz
freebsd-ports-gnome-a210caa700bafd0e1925d46f4a7fc2c171fcc139.tar.zst
freebsd-ports-gnome-a210caa700bafd0e1925d46f4a7fc2c171fcc139.zip
- use MAKE_JOBS_SAFE
PR: 156930 Submitted by: Matthias Andree
Diffstat (limited to 'graphics')
-rw-r--r--graphics/netpbm/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index e825442e92c2..4d9eb734995d 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jasper.4:${PORTSDIR}/graphics/jasper \
xml2.5:${PORTSDIR}/textproc/libxml2
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
USE_PERL5= yes
USE_GMAKE= yes
@@ -55,6 +55,16 @@ pre-configure:
@${LN} -sf ${WRKSRC}/lib/util/nstring.h ${WRKSRC}/lib/util/pm_nstring.h
cd ${WRKSRC} && buildtools/stamp-date > ${WRKSRC}/lib/compile.h
+# This snippet is all it takes to make the port as of 10.35.80 MAKE_JOBS_SAFE:
+pre-build:
+ @(cd ${BUILD_WRKSRC}/lib/util; if ! ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE2} ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}; then \
+ if [ x != x${BUILD_FAIL_MESSAGE} ] ; then \
+ ${ECHO_MSG} "===> Compilation failed unexpectedly."; \
+ (${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
+ fi; \
+ ${FALSE}; \
+ fi)
+
post-install:
@${ECHO_MSG} "===> Installing man pages..."
@${REINPLACE_CMD} -e 's|doc/USERDOC|${DOCSDIR}/USERDOC|g' \