aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-08 07:40:23 +0800
committermarino <marino@FreeBSD.org>2013-10-08 07:40:23 +0800
commita2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5 (patch)
treee61a78f0169c5b6d3db742a3a79532ae3afa9fab /graphics
parent75f2f17686803372411d7a488c3afc47442146cf (diff)
downloadfreebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.tar.gz
freebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.tar.zst
freebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.zip
Explicitly link libraries on 10 unmaintained ports
The following ports will not build with a binutils 2.22+ linker built with standard options. This has been obvious with DPorts, but difficult to see on FreeBSD. However, setting the ports compiler as a recent gcc (e.g lang/gcc48) is an excellent way to detect the unspecified but needed libraries as these recent GCC compilers use the latest binutils linkers. These patches were tested on FreeBSD 8.4 and DragonFly 3.5
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fv/Makefile2
-rw-r--r--graphics/kludge3d/Makefile2
-rw-r--r--graphics/pornview/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index dd31405bc6f6..eb85bec57c14 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -24,7 +24,7 @@ ALL_TARGET= ${PORTNAME}
CXXFLAGS+= $$(pkg-config --cflags libpng15) \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= $$(pkg-config --libs libpng15) \
- -L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm ${PTHREAD_LIBS}
+ -L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm -lz ${PTHREAD_LIBS}
PORTDOCS= AUTHORS ChangeLog README
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/kludge3d/Makefile b/graphics/kludge3d/Makefile
index 3aadbd8862d5..e755bf14c91c 100644
--- a/graphics/kludge3d/Makefile
+++ b/graphics/kludge3d/Makefile
@@ -25,7 +25,7 @@ PLIST_FILES= bin/kludge3d
CPPFLAGS+= -I${LOCALBASE}/include \
-I${PYTHON_INCLUDEDIR} ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
- -L${PYTHON_LIBDIR}/config ${PTHREAD_LIBS}
+ -L${PYTHON_LIBDIR}/config -lm ${PTHREAD_LIBS}
NO_STAGE= yes
post-patch:
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index 5cfa44f521d6..9e3450d7e13d 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk2
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= LIBXINE MPLAYER NLS
OPTIONS_DEFAULT= LIBXINE