aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-03-23 04:11:17 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-03-23 04:11:17 +0800
commitac55ba5a0857982266d6709e4f7919092af9c29d (patch)
tree1aaa406c7ea9a8f63429a44519860e83a4f339e1 /graphics
parent0b0aa40e59fb5bc7d61e5110935ae686bdfd9957 (diff)
downloadfreebsd-ports-gnome-ac55ba5a0857982266d6709e4f7919092af9c29d.tar.gz
freebsd-ports-gnome-ac55ba5a0857982266d6709e4f7919092af9c29d.tar.zst
freebsd-ports-gnome-ac55ba5a0857982266d6709e4f7919092af9c29d.zip
- Use -lpthread instead of -pthread
PR: 198116 Submitted by: marino
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gdal/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index f97650809af0..d648490d3d88 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ARGS= --datadir=${DATADIR} \
--with-threads=yes \
--without-libtool
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE} -pthread
+LDFLAGS+= -L${LOCALBASE} -lpthread
MAKE_JOBS_UNSAFE= yes
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
@@ -132,7 +132,6 @@ XERCES_LIB_DEPENDS= libxerces-c.so:${PORTSDIR}/textproc/xerces-c3
post-patch:
@${REINPLACE_CMD} -e 's|$$(INST_LIB)/pkgconfig|${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/GNUmakefile
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
# Cleanup bundled libraries
@${RM} -fr ${WRKSRC}/frmts/gif/giflib/
@${RM} -fr ${WRKSRC}/frmts/gtiff/libgeotiff/