aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2012-11-09 05:42:39 +0800
committerzeising <zeising@FreeBSD.org>2012-11-09 05:42:39 +0800
commitb7b2f4371d710445e1f2fa1924629945104d25ae (patch)
treec5c55d00bc47efe77bffc8d275e5a7c229eca416 /graphics
parent98cd85eb711fb5fbaf756d70f651a4cede139707 (diff)
downloadfreebsd-ports-gnome-b7b2f4371d710445e1f2fa1924629945104d25ae.tar.gz
freebsd-ports-gnome-b7b2f4371d710445e1f2fa1924629945104d25ae.tar.zst
freebsd-ports-gnome-b7b2f4371d710445e1f2fa1924629945104d25ae.zip
Remove unneeded sed in post-patch.
Convert to OptionsNG While here, fix whitespace in Makefile header. PR: ports/173443 Submitted by: nemysis <nemysis@gmx.ch> Approved by: kwm, miwi (mentors, implicit) Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/feh/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index d451f3b01eba..ce7655baf451 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -1,4 +1,4 @@
-# Created by: Jeremy Norris <ishmael27@home.com>
+# Created by: Jeremy Norris <ishmael127@home.com>
# $FreeBSD$
PORTNAME= feh
@@ -29,16 +29,16 @@ MAKE_ENV+= LDFLAGS="${LDFLAGS}"
PORTDOCS= AUTHORS ChangeLog README TODO
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} 's#/bin/bash#/bin/sh#' ${WRKSRC}/cam/gen-cam-menu
- @${REINPLACE_CMD} 's#/install-man install-doc#install-man#' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's#/install-man install-doc#install-man#' \
+ ${WRKSRC}/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOC}
@${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>