aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-09-25 18:31:36 +0800
committerak <ak@FreeBSD.org>2013-09-25 18:31:36 +0800
commitb8edbafc4e1b6ec44844c903224b64e057e522be (patch)
tree094955fec55d7980747d810784295f1e23631af5 /graphics
parent6f7c0dd960518d0ecdfdb25f40a33b033c42abe4 (diff)
downloadfreebsd-ports-gnome-b8edbafc4e1b6ec44844c903224b64e057e522be.tar.gz
freebsd-ports-gnome-b8edbafc4e1b6ec44844c903224b64e057e522be.tar.zst
freebsd-ports-gnome-b8edbafc4e1b6ec44844c903224b64e057e522be.zip
- Support STAGEDIR
- Add x11 as secondary category
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xmountains/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/xmountains/Makefile b/graphics/xmountains/Makefile
index 74746d214c86..423efa81d8d5 100644
--- a/graphics/xmountains/Makefile
+++ b/graphics/xmountains/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmountains
PORTVERSION= 2.9
-CATEGORIES= graphics
+CATEGORIES= graphics x11
MASTER_SITES= ftp://ftp.uwsg.indiana.edu/linux/debian/pool/main/x/xmountains/ \
ftp://ftp.fi.netbsd.org/.m/mirrors1/archive.ubuntu.com/pool/universe/x/xmountains/ \
ftp://ftp.mirrorservice.org/sites/archive.raspbian.org/raspbian/pool/main/x/xmountains/ \
@@ -18,12 +18,11 @@ NO_WRKSUBDIR= yes
USE_XORG= xbitmaps x11
-MAN6= ${PORTNAME}.6
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-NO_STAGE= yes
post-extract:
@${LN} -sf ${PORTNAME}.man ${WRKSRC}/${PORTNAME}.6
@@ -31,7 +30,7 @@ do-build:
cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} *.c -lX11 -lm -o ${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${MAN6PREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
.include <bsd.port.mk>