aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-02 21:16:03 +0800
committerpawel <pawel@FreeBSD.org>2012-11-02 21:16:03 +0800
commitb93b6422454f801e929cfb941c682b5b24d3f155 (patch)
treea35e8d8ed7724deede3e55f6da7d544e69119f66 /graphics
parent85b683f13c4582ab1ad6219447b30a11e5578a6d (diff)
downloadfreebsd-ports-gnome-b93b6422454f801e929cfb941c682b5b24d3f155.tar.gz
freebsd-ports-gnome-b93b6422454f801e929cfb941c682b5b24d3f155.tar.zst
freebsd-ports-gnome-b93b6422454f801e929cfb941c682b5b24d3f155.zip
- Update to version 2.4.9
- Add LICENSE - Remove ABI versions from LID_DEPENDS PR: ports/172241 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/grx/Makefile62
-rw-r--r--graphics/grx/distinfo4
-rw-r--r--graphics/grx/pkg-descr8
-rw-r--r--graphics/grx/pkg-plist2
4 files changed, 42 insertions, 34 deletions
diff --git a/graphics/grx/Makefile b/graphics/grx/Makefile
index 8df69d4ac695..c55870890bf9 100644
--- a/graphics/grx/Makefile
+++ b/graphics/grx/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: grx
-# Date created: 1 Jul 2006
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= grx
-PORTVERSION= 2.4.8
-PORTREVISION= 1
+PORTVERSION= 2.4.9
CATEGORIES= graphics
MASTER_SITES= http://grx.gnu.de/download/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -15,21 +10,31 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= A 2D graphics library
+LICENSE= LGPL20 MIT
+LICENSE_COMB= multi
+
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ xcb:${PORTSDIR}/x11/libxcb
+
+OPTIONS_DEFINE= BGI BMP JPEG PNG PRINT TIFF ZLIB
+OPTIONS_DEFAULT= ZLIB BGI BMP PNG PRINT
+BGI_DESC= Enable BGI support
+BMP_DESC= Enable BMP support
+
+USE_XORG= x11 xau xdmcp
USE_GMAKE= yes
-USE_XORG= x11
-USE_LDCONFIG= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --with-fontpath=${DATADIR}/fonts \
--with-x11-base=${LOCALBASE}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
ALL_TARGET= libs
INSTALL_TARGET= install install-bin install-fonts install-info
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
-OPTIONS_DEFINE= BGI BMP JPEG PNG PRINT TIFF ZLIB
-OPTIONS_DEFAULT= ZLIB BGI BMP PNG PRINT
-BGI_DESC= Enable BGI support
-BMP_DESC= Enable BMP support
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_SUB= VERSION="${PORTVERSION}"
INFO= grx
@@ -50,7 +55,7 @@ CONFIGURE_ARGS+=--disable-bmp
.endif
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--enable-jpeg
.else
CONFIGURE_ARGS+=--disable-jpeg
@@ -72,7 +77,7 @@ PLIST_SUB+= PRINT="@comment "
.endif
.if ${PORT_OPTIONS:MTIFF}
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= tiff:${PORTSDIR}/graphics/tiff
CONFIGURE_ARGS+=--enable-tiff
.else
CONFIGURE_ARGS+=--disable-tiff
@@ -84,7 +89,9 @@ CONFIGURE_ARGS+=--enable-zlib
CONFIGURE_ARGS+=--disable-zlib
.endif
-.if ${ARCH} == amd64
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
CONFIGURE_ARGS+=--enable-x86_64
.endif
@@ -96,13 +103,16 @@ post-patch:
@${GREP} -ERl '<(malloc|alloca)\.h>' ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -Ee 's|<(malloc\|alloca)\.h>|<stdlib.h>|'
@${REINPLACE_CMD} -Ee \
- 's|-m32||; s|-m64||; \
- s|^(CC[[:blank:]]*=).*|\1 ${CC}|; \
- s|^(CCOPT =)|\1 ${CPPFLAGS} ${CFLAGS}|; \
- s|^(LDOPT =)|\1 ${LDFLAGS}|;' \
- -e 's|lib64|lib|' \
+ 's|-m32|| ; \
+ s|-m64|| ; \
+ s|^(CC[[:blank:]]*=).*|\1 ${CC}| ; \
+ s|^(CCOPT =)|\1 ${CPPFLAGS} ${CFLAGS}| ; \
+ s|^(LDOPT =)|\1 ${LDFLAGS}| ; \
+ s|lib64|lib|' \
${WRKSRC}/makedefs.grx
- @${REINPLACE_CMD} -e 's|gcc|${CC}|' -e 's|lib64|lib|' \
- ${WRKSRC}/src/makefile.[lx]*
+ @${REINPLACE_CMD} -e \
+ 's|gcc|${CC}| ; \
+ s|lib64|lib|' \
+ ${WRKSRC}/src/makefile.[lx]*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/grx/distinfo b/graphics/grx/distinfo
index e918e2f6ed83..a7aa0c7c6230 100644
--- a/graphics/grx/distinfo
+++ b/graphics/grx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grx248.tar.gz) = 57e565689b7d0909f61818e9be0dbc14e6bceaa0b996ee84aca7fcb37a6733ed
-SIZE (grx248.tar.gz) = 1510074
+SHA256 (grx249.tar.gz) = a899956b3ee46492696114d220431405320c64c1f6f058fdfc2b4d6a2beae786
+SIZE (grx249.tar.gz) = 1514962
diff --git a/graphics/grx/pkg-descr b/graphics/grx/pkg-descr
index 9802b1b823ea..00be426efb15 100644
--- a/graphics/grx/pkg-descr
+++ b/graphics/grx/pkg-descr
@@ -1,7 +1,5 @@
-GRX is a 2D graphics library originaly written by Csaba Biegl for DJ Delorie's
-DOS port of the GCC compiler.
-
-Now it support DOS (using the DJGPP v2 compiler), Linux console, X11 and Win32
-(using the Mingw compiler).
+GRX is a 2D graphics C library originaly written by Csaba Biegl for
+DJ Delorie's DOS port of the GCC compiler. Now it support a big range
+of platforms.
WWW: http://grx.gnu.de/
diff --git a/graphics/grx/pkg-plist b/graphics/grx/pkg-plist
index 0845f3daf180..9d087c21b7b4 100644
--- a/graphics/grx/pkg-plist
+++ b/graphics/grx/pkg-plist
@@ -8,7 +8,7 @@ include/libbcc.h
lib/libgrx20X.a
lib/libgrx20X.so
lib/libgrx20X.so.2
-lib/libgrx20X.so.2.4.8
+lib/libgrx20X.so.%%VERSION%%
%%DATADIR%%/fonts/char11.fnt
%%DATADIR%%/fonts/char11b.fnt
%%DATADIR%%/fonts/char11bi.fnt