aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-06-22 19:12:42 +0800
committeredwin <edwin@FreeBSD.org>2008-06-22 19:12:42 +0800
commitc1df777890b8ebe630dd46af31e9e78abd94dc14 (patch)
tree9acf3f15bc37084522ac42534798e8724c546eaa /graphics
parent6f507e96af9bc0d82d0b24e7acef5b3182d0c49f (diff)
downloadfreebsd-ports-gnome-c1df777890b8ebe630dd46af31e9e78abd94dc14.tar.gz
freebsd-ports-gnome-c1df777890b8ebe630dd46af31e9e78abd94dc14.tar.zst
freebsd-ports-gnome-c1df777890b8ebe630dd46af31e9e78abd94dc14.zip
- Fix startup script for when you're not in /usr/local/libexec/processing-devel.
- Fix warnings about world writable files.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/processing-devel/Makefile2
-rw-r--r--graphics/processing-devel/files/patch-processing13
2 files changed, 12 insertions, 3 deletions
diff --git a/graphics/processing-devel/Makefile b/graphics/processing-devel/Makefile
index 2820f8b46b13..2e60cfa036be 100644
--- a/graphics/processing-devel/Makefile
+++ b/graphics/processing-devel/Makefile
@@ -27,6 +27,8 @@ post-extract:
${RM} -rf ${WRKSRC}/java/[A-Z]*
${RM} -rf ${WRKSRC}/java/lib/[a-qsu-z]*
+ ${FIND} ${WRKSRC}/reference -type f -exec ${CHMOD} go-xw {} \;
+
post-patch:
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/processing
${RM} ${WRKSRC}/processing.*
diff --git a/graphics/processing-devel/files/patch-processing b/graphics/processing-devel/files/patch-processing
index f36b97693738..04a0b8af0292 100644
--- a/graphics/processing-devel/files/patch-processing
+++ b/graphics/processing-devel/files/patch-processing
@@ -1,6 +1,6 @@
--- processing.orig 2008-06-16 22:21:27.000000000 +1000
-+++ processing 2008-06-22 18:03:16.000000000 +1000
-@@ -1,6 +1,6 @@
++++ processing 2008-06-22 21:08:13.000000000 +1000
+@@ -1,17 +1,17 @@
- #!/bin/sh
+#!/bin/sh
@@ -9,7 +9,14 @@
for LIB in \
java/lib/rt.jar \
-@@ -14,4 +14,4 @@
+ java/lib/tools.jar \
+ lib \
+ lib/build \
+- lib/*.jar \
++ lib/antlr.jar lib/core.jar lib/jna.jar lib/pde.jar \
+ ;
+ do
+ CLASSPATH="${CLASSPATH}:${APPDIR}/${LIB}"
done
export CLASSPATH