aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 13:33:51 +0800
committeraz <az@FreeBSD.org>2013-07-26 13:33:51 +0800
commitc1e6f9b1282b29ade869dbab3f1768fbcc2443a6 (patch)
treeeb22256c13100460a384a64ae5d3fbefbaab9ab7 /graphics
parentd52530844c122dbe12c5c32217f4ffdae83fe830 (diff)
downloadfreebsd-ports-gnome-c1e6f9b1282b29ade869dbab3f1768fbcc2443a6.tar.gz
freebsd-ports-gnome-c1e6f9b1282b29ade869dbab3f1768fbcc2443a6.tar.zst
freebsd-ports-gnome-c1e6f9b1282b29ade869dbab3f1768fbcc2443a6.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cadubi/Makefile4
-rw-r--r--graphics/gtkgraph/Makefile8
-rw-r--r--graphics/p5-GD-Graph3d/Makefile11
-rw-r--r--graphics/p5-Image-IPTCInfo/Makefile11
4 files changed, 10 insertions, 24 deletions
diff --git a/graphics/cadubi/Makefile b/graphics/cadubi/Makefile
index 3e8552b4cc42..e6d79259f23c 100644
--- a/graphics/cadubi/Makefile
+++ b/graphics/cadubi/Makefile
@@ -25,8 +25,8 @@ PORTDOCS= *
.include <bsd.port.options.mk>
do-configure:
- @${PERL} -pi -e \
- 's|Bin/help|Bin/../share/cadubi/help|g' ${WRKSRC}/cadubi
+ @${REINPLACE_CMD} -i '' -e 's|Bin/help|Bin/../share/cadubi/help|' \
+ ${WRKSRC}/cadubi
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
index 6e2f73973e84..48b046ac9892 100644
--- a/graphics/gtkgraph/Makefile
+++ b/graphics/gtkgraph/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtkgraph
-# Date created: 12 October 1999
-# Whom: Chris D. Faulhaber <jedgar@fxp.org>
-#
+# Created by: Chris D. Faulhaber <jedgar@fxp.org>
# $FreeBSD$
-#
PORTNAME= gtkgraph
PORTVERSION= 0.6.1
@@ -24,7 +20,7 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; s|-O2|${CFLAGS}| ; \
+ @${REINPLACE_CMD} -i '' -e 's|-O2|${CFLAGS}| ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Graph3d/Makefile b/graphics/p5-GD-Graph3d/Makefile
index 76b5a4f6ba80..c201ea05c387 100644
--- a/graphics/p5-GD-Graph3d/Makefile
+++ b/graphics/p5-GD-Graph3d/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-GD-Graph
-# Date created: 10 April 2000
-# Whom: Dmitry Sivachenko <dima@Chg.RU>
-#
+# Created by: Dmitry Sivachenko <dima@Chg.RU>
# $FreeBSD$
-#
PORTNAME= GD-Graph3d
PORTVERSION= 0.63
@@ -19,11 +15,8 @@ BUILD_DEPENDS= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+USE_DOS2UNIX= lib/GD/Graph3d.pm # pod2man doesn't work without this
MAN3= GD::Graph3d.3
-post-patch:
-# pod2man doesn't work without this
- ${PERL} -pi -e 's/\r//' ${WRKSRC}/lib/GD/Graph3d.pm
-
.include <bsd.port.mk>
diff --git a/graphics/p5-Image-IPTCInfo/Makefile b/graphics/p5-Image-IPTCInfo/Makefile
index 150c3c96a69a..56baf249e8ba 100644
--- a/graphics/p5-Image-IPTCInfo/Makefile
+++ b/graphics/p5-Image-IPTCInfo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Image-IPTCInfo
-# Date created: 2006-08-11
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Image-IPTCInfo
PORTVERSION= 1.95
@@ -15,12 +11,13 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for extracting IPTC image meta-data
PERL_CONFIGURE= yes
+USES= shebangfix
+SHEBANG_FILES= demo.pl
MAN3= Image::IPTCInfo.3
post-patch:
- ${RM} -f ${WRKSRC}/._*
- ${PERL} -pi -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/demo.pl
+ @${RM} -f ${WRKSRC}/._*
.if !defined(NOPORTDOCS)
post-install: